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Chapter	3:	Basic	Sketch	Based	Features
Sketch-Based	features	are	used	to	create	basic	and	simple	parts.	Most	of	the	times,	they
form	the	base	for	complex	parts	as	well.	These	features	are	easy	to	create	and	require	a
single	sketch.	Now,	you	will	learn	the	commands	to	create	these	features.

	

The	topics	covered	in	this	chapter	are:

	

Pad	Features
Shaft	Feature
Pocket	Features
Reference	Planes
More	Options	in	the	Pad	and	Shaft	commands
View		commands

	

	Pad
Pad	is	the	process	of	taking	a	two-dimensional	profile	and	converting	it	into	3D	feature	by
giving	it	some	thickness.	A	simple	example	of	this	would	be	taking	a	circle	and	converting
it	into	a	cylinder.

	

1.	 Once	you	have	created	a	sketch	profile	or	profiles	you	want	to	Pad,	activate	the	Pad
command	(On	the	Sketch-Based	Features	toolbar,	click	Pads	drop-down	>	Pad	(or)
click	Insert	>	Sketch-Based	Features	>	Pad	on	the	Menu).

2.	 Click	on	the	sketch	profile	to	add	thickness	to	it.

3.	 On	the	Pad	Definition	dialog,	type-in	a	value	in	the	Length	box.



4.	 If	you	want	to	add	equal	thickness	on	both	sides	of	the	sketch,	then	check	the	Mirror
extent	option.

5.	 Click	the	Preview	button	to	view	how	the	model	would	look	when	completed.

6.	 Click	OK	to	complete	the	Pad	feature.

	

While	creating	a	Pad	feature,	CATIA	adds	material	in	the	direction	normal	to	the	sketch.

If	 you	want	 to	manually	 define	 the	 direction	 in	which	 the	material	will	 be	 added,	 then
click	the	More	button	on	the	Pad	Definition	dialog.	Click	in	the	Reference	selection	box
and	select	a	line.



	

	Shaft
Revolving	is	the	process	of	taking	a	two-dimensional	profile	and	revolving	it	about	a
centerline	to	create	a	3D	geometry	(shapes	that	are	axially	symmetric).	While	creating	a
sketch	for	the	Shaft	feature,	it	is	important	to	think	about	the	cross-sectional	shape	that
will	define	the	3D	geometry	once	it	is	revolved	about	an	axis.	For	instance,	the	following
geometry	has	a	hole	in	the	center.

This	could	be	created	with	a	 separate	Pocket	or	Hole	 feature.	But	 in	order	 to	make	 that
hole	part	of	the	Shaft	feature,	you	need	to	sketch	the	axis	of	revolution	so	that	it	leaves	a
space	between	the	profile	and	the	axis.

1.	 After	completing	the	sketch,	activate	the	Shaft	command	(On	the	Profile	toolbar,	click
the	Shaft	icon	(or)	click	Insert	>	Sketch-Based	Features	>	Shaft	on	the	Menu).

2.	 The	sketch	will	be	revolved	by	full	360	degrees.

3.	 If	you	want	to	enter	an	angle	of	revolution,	type-in	a	value	in	the	First	Angle	box.



4.	 On	the	dialog,	click	OK	to	complete	the	Shaft	feature.

	

	Project	3D	Elements
This	command	projects	the	edges	of	a	3D	geometry	onto	a	sketch	plane.

	

1.	 Activate	the	Sketcher	Workbench	by	selecting	a	plane	or	model	face.
2.	 On	the	Operations	toolbar,	click	3D	Geometry	drop-down	>	Project	3D	Elements

(or)	click	Insert	>	Operations	>	3D	Geometry	>	Project	3D	Elements	on	the	Menu.
3.	 Click	on	the	edges	of	the	model	geometry	to	project	them	on	to	the	sketch	plane.
4.	 Click	OK	on	the	Projection	dialog.

The	projected	element	will	be	yellow	in	color	and	fully	constrained.	If	you	want	to	convert
it	into	a	normal	sketch	element,	then	right	click	on	it	and	select	Mark.object	>	Isolate.

	

5.	 Complete	the	sketch	and	exit	the	workbench.



	The	Pocket	command
This	command	removes	material	from	the	geometry	by	extruding	a	sketch.	It	functions	on
the	same	lines	of	the	Pad	command.

	
1.	 Draw	a	sketch	on	a	plane	or	a	model	face.
2.	 On	the	Sketch-Based	Features	toolbar,	click	the	Pocket	icon	(or)	click	Insert	>

Sketch-Based	Features	>	Pocket	on	the	Menu.
3.	 Select	the	sketch.

4.	 On	the	Pocket	Definition	dialog,	type-in	a	value	in	the	Depth	box	and	click	Preview.

5.	 If	you	want	to	define	the	direction	of	material	removal,	then	the	More	button	to	expand
the	dialog.

6.	 Click	in	the	Reference	selection	box	and	select	an	edge	or	line	to	define	the	direction.



7.	 Click	OK	to	complete	the	pocket	feature.

	

	The	Groove	command
This	command	removes	material	from	the	geometry	by	revolving	a	sketch	about	an	axis.	It
functions	in	a	way	similar	to	the	Shaft	command.

	

1.	 Draw	a	sketch	on	a	plane	or	a	model	face.	Also,	draw	a	centerline	using	the	Centerline
command.

2.	 On	the	Sketch-Based	Features	toolbar,	click	the	Groove	icon	(or)	click	Insert	>
Sketch-Based	Features	>	Groove	on	the	Menu.

3.	 Select	the	sketch.	If	you	have	created	the	centerline,	then	groove	will	be	created
automatically.

4.	 On	the	Groove	Definition	dialog,	type-in	values	in	the	First	angle	and	Second	angle
boxes.

5.	 Click	OK	to	complete	the	groove	feature.



	The	Plane	command
Each	time	you	start	a	new	part	file,	CATIA	V5	automatically	creates	default	Reference
planes.	Planes	are	a	specific	type	of	elements	in	CATIA	V5,	known	as	Reference
Elements.	These	features	act	as	supports	to	your	3D	geometry.	In	addition	to	the	default
Reference	features,	you	can	create	your	own	additional	planes.	Until	now,	you	have
learned	to	create	sketches	on	any	of	the	default	reference	planes	(XY,	YZ,	and	XZ	planes).
If	you	want	to	create	sketches	and	geometry	at	locations	other	than	default	reference
planes,	you	can	create	new	reference	planes	manually.	You	can	do	this	by	using	the	Plane
command.

Offset	from	plane
This	method	creates	a	reference	plane,	which	will	be	parallel	to	a	face	or	another	plane.

	

1.	 Activate	the	Plane	command	(On	the	Reference	Elements	toolbar,	click	the	Plane).
2.	 On	the	Plane	Definition	dialog,	select	Plane	type	>	Offset	from	plane.

	

	

3.	 Select	flat	face.



4.	 Drag	the	Offset	arrow	that	appears	on	the	plane	(or)	type-in	a	value	in	the	Offset	box	to
define	the	offset	distance.

5.	 On	the	dialog,	you	can	click	the	Reverse	Direction	button	to	flip	the	plane	to	other
side	of	the	model	face.

6.	 If	you	want	to	create	more	than	one	offset	plane,	then	check	the	Repeat	object	after
OK	option	and	click	OK.

7.	 On	the	Object	Repetion	dialog,	type-in	a	value	in	the	Instance	(s)	box.
8.	 Check	the	Create	a	new	body	option,	if	you	want	to	create	the	repeated	planes	as	a

separate	body.

	

	

9.	 Click	OK	to	create

Parallel	through	Point
This	method	creates	a	plane	parallel	to	a	flat	face	at	a	selected	point.

	

1.	 Activate	the	Plane	command.
2.	 On	the	Plane	Definition	dialog,	select	Plane	type	>	Parallel	through	point,	and	then

select	a	flat	face.
3.	 Select	a	point	to	define	the	parallel	plane	location.



Angle/Normal	to	plane
This	method	creates	a	plane,	which	will	be	positioned	at	an	angle	to	a	face	or	plane.

	

1.	 Activate	the	Plane	command.

	

	

2.	 Select	a	flat	face	or	plane	to	define	the	reference.
3.	 Select	Plane	type	>	Angle/Normal	to	plane	on	the	Plane	Definition	dialog.
4.	 Click	on	an	edge	of	the	part	geometry	to	define	the	rotation	axis.
5.	 Type-in	a	value	in	the	Angle	box	and	press	Enter.

6.	 On	the	Plane	Definition	dialog,	click	the	Normal	to	plane	button	to	create	a	plane
normal	to	the	reference.

7.	 Click	OK.



Through	three	points
This	method	creates	a	plane	by	selecting	three	points.

	

1.	 Activate	the	Plane	command.
2.	 Select	three	points	from	the	model	geometry.
3.	 Click	OK	to	create	a	plane	passing	through	the	points.

Through	two	lines
This	method	creates	a	plane	by	selecting	two	lines.

	

1.	 Activate	the	Plane	command.
2.	 Select	two	lines	from	the	model	geometry.
3.	 Click	OK.

Through	point	and	line
This	method	creates	a	plane	by	selecting	a	point	and	line.

	



1.	 Activate	the	Plane	command.
2.	 Select	a	point	and	line.
3.	 Click	OK.

Through	planar	curve
This	method	creates	a	plane	by	selecting	a	non-linear	planar	curve.

Normal	to	curve
This	method	 creates	 a	 reference	 plane,	 which	will	 be	 normal	 (perpendicular)	 to	 a	 line,
curve,	or	edge.

	

1.	 On	the	Plane	Definition	dialog,	click	Plane	type	>	Normal	to	Curve	and	select	an
edge,	line,	curve,	arc,	or	circle.

2.	 Click	on	a	point	to	define	the	location	of	the	plane.

Tangent	to	surface
This	method	creates	a	plane	tangent	to	a	curved	face.

	

1.	 On	 the	Plane	Definition	dialog,	click	Plane	type	>	Tangent	to	surface	and	select	a
curved	face.



2.	 Click	on	a	point.	A	plane	tangent	to	the	selected	face	appears.

Equation
This	method	creates	a	plane	using	the	equation	Ax+By+Cz=D.	You	have	to	type-in	A,	B,
C,	and	D	values.

	

1.	 On	the	Plane	Definition	dialog,	click	Plane	type	>	Equation.
2.	 Type-in	values	in	the	A,	B,	C,	and	D	boxes	on	the	Plane	Definition	box.	The	x,	y,	z

coordinates	will	be	calculated	automatically	and	a	plane	will	be	created	at	 the	origin
passing	though	the	x,	y,	z	coordinates.

	
If	you	want	to	create	a	plane	normal	to	the	compass,	then	click	the	Normal	to	compass
button	and	type-in	values	in	the	C	and	D	boxes.	A	plane	normal	to	the	compass	will	be
created	at	distance	D/C	from	the	origin.

	

Click	the	Parallel	to	Screen	button	to	create	a	plane	parallel	to	screen.

	

Mean	through	points
This	method	creates	a	plane	passing	through	points.

	

1.	 On	the	Plane	Definition	dialog,	click	Plane	type	>	Mean	through	points.
2.	 Select	multiple	points	to	create	a	plane.



	Point
The	Point	command	creates	points	in	the	3D	space	using	seven	different	methods.
Following	sections	explain	you	to	create	points	using	these	methods.

	

Coordinates
This	method	creates	a	point	in	the	3D	space	by	using	the	X,	Y,	Z	coordinates	that	you
specify.

	

1.	 Activate	 the	 Point	 command	 (on	 the	Reference	 Elements	 toolbar,	 click	 the	 Point
icon).

2.	 On	the	Point	Definition	dialog,	click	Point	type	>	Coordinates.
3.	 On	the	Point	Definition	dialog,	type-in	the	X,	Y,	Z	coordinates.

	

	

A	point	will	be	created	with	reference	to	origin	(0,	0,	0).

If	you	want	to	create	a	point	with	reference	to	a	point	other	than	the	origin,	then	select	a
point	from	the	graphics	window.



On	curve
This	method	creates	a	point	on	a	curve.

	

1.	 Activate	the	Point	command	and	click	on	a	curve	or	edge.
2.	 Move	the	pointer	and	click	to	define	the	location	of	the	point	on	the	curve.

On	Plane
This	method	creates	point	on	a	planar	face.

	

1.	 Activate	the	Point	command	and	click	on	a	planar	face	or	plane.

If	you	want	to	create	the	point	with	reference	to	a	point	other	than	the	origin,	then	click	in
the	Point	selection	box	on	the	Point	Definition	dialog	and	click	to	define	a	reference
point.



If	you	want	to	project	the	new	point	on	to	a	surface,	then	click	in	the	Surface	selection
box	and	select	a	surface.

2.	 Move	the	pointer	and	click	to	define	the	location	of	the	point	(or)	type-in	values	in	the
H	and	V	boxes	on	the	Point	Definition	dialog.

	

On	Surface
This	method	creates	point	on	a	surface.

	

1.	 Activate	the	Point	command	and	click	on	a	surface.



2.	 On	the	Point	Definition	dialog,	click	in	the	Point	selection	box	and	define	a	reference
point	on	the	selected	surface.

3.	 On	the	Point	Definition	dialog,	right	click	in	the	Direction	selection	box	and	select	an
option	to	define	the	direction	of	the	point.	For	example,	select	Y	Component	to	create
the	point	in	the	Y-direction.

4.	 Select	the	Dynamic	Positioning	option.
5.	 Move	the	pointer	and	click	to	define	the	location	of	the	point.

Circle/Sphere/Ellipse	center
This	method	creates	a	point	at	the	center	of	an	arc,	circle,	sphere	or	ellipse.

	

1.	 On	the	Point	Definition	dialog,	click	Point	type	>	Circle/Sphere/Ellipse	center.
2.	 Click	on	an	arc,	circle,	sphere,	or	elliptical	entity.

Tangent	on	curve
This	method	creates	a	point	tangent	to	a	curve.

	

1.	 On	the	Point	Definition	dialog,	click	Point	type	>	Tangent	on	curve.



2.	 Click	on	an	edge	or	curve.
3.	 Click	on	an	edge	or	right	click	and	select	an	option	to	define	the	tangential	direction.
4.	 Click	OK	to	create	the	point.

Between
This	method	creates	a	point	between	two	points.

	

1.	 On	the	Point	Definition	dialog,	click	Point	type	>	Between.
2.	 Select	two	points	from	the	graphics	window	or	model	geometry.

3.	 Type-in	a	value	in	the	Ratio	box.	For	example,	if	you	type-in	0.5,	the	point	will	be
created	at	the	midpoint.

4.	 Click	on	the	face,	curve,	or	edge	to	define	the	supporting	element.
5.	 Click	OK	to	create	the	point.

	



	Line
The	Line	command	(on	the	Reference	Elements	toolbar,	click	the	Line	icon)	creates	a
line	in	the	3D	space.	The	methods	to	create	lines	using	this	command	are	explained	next.

	

Point-Point

	

	

	

	

Point-Direction

Angle/Normal	to	curve



Tangent	to	curve

	
	
Normal	to	surface

Bisecting

Additional	options	of	the	Pad	and	Pocket	commands



The	Pad	and	Pocket	commands	have	some	additional	options	to	create	a	3D	geometry,
complex	features,	and	so	on.

	

Limits
On	the	Pad	Definition	or	Pocket	Definition	dialog,	the	First	Limit	and	Second	Limit
sections	have	various	options	to	define	the	start	and	end	limits	of	the	Pad	or	Pocket
feature.	These	options	are	Dimension,	Up	to	next,	Up	to	last,	Up	to	plane,	and	Up	to
surface.

	

The	Up	to	next	option	extrudes	the	sketch	through	the	face	next	to	the	sketch	plane.

	

The	Up	to	surface	option	extrudes	the	sketch	up	to	a	selected	surface.

The	Up	to	plane	option	extrudes	the	sketch	from	the	sketch	plane	up	to	a	selected	planar
face.

	



The	Up	to	last	option	extrudes	the	sketch	throughout	the	3D	geometry.

	

Thick
The	Thick	option	will	help	you	to	add	thickness	to	the	selected	sketch.	Check	this	option
on	the	Pad	Definition	or	Revolve	Definition	dialog	to	add	thickness	to	the	sketch.	Click
the	More	button	to	view	the	Thickness	1	and	Thickness	2	boxes.	Type-in	thickness
values	in	these	boxes.	Check	the	Neutral	Fiber	option,	if	you	want	to	add	thickness
symmetrically	on	both	sides	of	the	sketch.



	

	The	Drafted	Filleted	Pad	command
This	command	creates	a	drafted	pad	feature	with	fillets.

	

1.	 Draw		the	sketch	and	exit	the	workbench.
2.	 On	the	Sketch-Based	Features	toolbar,	click	Pads	drop-down	>	Drafted	Filleted	Pad

(or)	click	Insert	>	Sketch-Based	Features	>	Drafted	Filleted	Pad	on	the	Menu.
3.	 On	the	Drafted	Filleted	Pa1d	Definition	dialog,	define	the	First	Limit,	Draft,	and

Fillets.

	



	

4.	 Click	on	a	face	or	plane	parallel	to	the	sketch	plane.

5.	 Click	OK.

You	will	notice	that	the	pad,	draft,	and	fillets	are	created	as	separate	features.



	The	Drafted	Filleted	Pocket	command
This	command	creates	a	drafted	pocket	with	fillets.

	

1.	 Draw	a	sketch	and	exit	the	workbench.
2.	 On	the	Sketch-Based	Features	toolbar,	click	Pokets	drop-down	>	Drafted	Filleted

Pocket	(or)	click	Insert	>	Sketch-Based	Features	>	Drafted	Filleted	Pocket	on	the
Menu.

3.	 Define	the	parameters	on	the	dialog	and	select	the	Second	limit.

4.	 Click	OK.



	The	Multi-Pad	command
This	command	takes	a	sketch	with	internal	loops	and	adds	multiple	thicknesses	to	it.

	

1.	 Draw	a	sketch,	which	contains	internal	loops.	Exit	the	workbench.

2.	 On	the	Sketch-Based	Features	toolbar,	click	Pads	drop-down	>	Multi-Pad	(or)	click
Insert	>	Sketch-Based	Features	>	Multi-Pad	on	the	Menu.

3.	 On	the	Multi-Pad	Definition	dialog,	click	on	the	Extrusion	Domains	one-by-one	and
type-in	values	in	the	Length	box.

4.	 If	you	want	to	extrude	the	loops	in	both	the	directions,	then	click	the	More	button	on
the	dialog	and	define	parameters	in	the	Second	Limit	section.

5.	 You	can	also	define	the	direction	of	the	extrusion	using	the	Direction	section.
6.	 Click	OK.

	The	Multi-Pocket	command
This	command	uses	a	multi-loop	sketch	to	remove	material	with	multiple	depths.

	

1.	 Draw	a	sketch,	which	contains	internal	loops.	Exit	the	workbench.

	



2.	 On	the	Sketch-Based	Features	toolbar,	click	Pokets	drop-down	>	Multi-Pocket	(or)
click	Insert	>	Sketch-Based	Features	>	Multi-Pocket	on	the	Menu.

3.	 On	the	Multi-Pocket	Definition	dialog,	select	the	extrusion	domains	and	define	the
pocket	depth.

4.	 Click	OK.

The	Apply	Material	command
This	command	applies	material	to	the	solid	geometry.

	

1.	 Activate	this	command	by	clicking	the	Apply	Material	button	on	the	Apply	Material
toolbar.

2.	 Click	on	a	tab	on	the	Library	dialog.
3.	 Select	the	material	from	the	dialog,	and	then	click	on	the	part	geometry.
4.	 Click	Apply	Material	to	apply	material	to	the	geometry.
5.	 Click	OK	to	close	the	dialog.

	

	

	



View	commands
The	 model	 display	 in	 the	 graphics	 window	 can	 be	 determined	 using	 various	 view
commands.	Most	of	these	commands	are	located	on	View	 toolbar	or	on	the	View	menu.
The	following	are	some	of	the	main	view	commands:

	

Fit	All	In
The	model	will	be	fitted	in	the	current	size	of
the	graphics	window	so	that	it	will	be	visible,
completely.

Pan
Activate	this	command	and	press	the	left	mouse
button.	Drag	the	pointer	to	move	the	model
view	on	plane	parallel	to	screen.

Rotate
Activate	this	command	and	press	the	left	mouse
button.	Drag	the	pointer	to	rotate	the	model
view.

Zoom	In Click	this	button	to	zoom	in	to	the	geometry.

Zoom	Out Click	this	button	to	zoom	out	of	the	geometry.

Normal	View
Activate	this	command	and	click	on	a	plane	or
face.	The	plane	will	become	normal	to	the
screen.

Create	 Multi-
View

This	command	creates	a	multi	viewpoint	in	the
graphics	window.

Shading	 with
Edges

This	represents	the
model	with	shades
along	with	visible
edges.

Shading	with
Edges	without
Smooth	Edges

This	represents	the
model	with	shades
along	with	visible
edges.	The	smooth
edges	of	the	curved
faces	will	be	hidden.



Shading

This	represents	the
model	with	shades
without	visible
edges.

Shading	with
Material

This	represents	the
model	with	shades
of	the	applied
material.

Wireframe
(NHR)

This	represents	the
model	in	wireframe.

Customize
view
Parameters

This	command	is
used	to	create	your
own	render	style	by
customizing	the
view	parameters.

	

Shading	 with
Edges	 and
Hidden	Edges

This	represents	the
model	in	shades
along	with	hidden
edges

	

Quick	View
Drop-down

Use	this	drop-down	to	change	the	model	view
orientation.



	



Measure	Commands

The	measure	commands	help	you	to	measure	the	physical	properties	of	geometry.	These
commands	are	explained	next.

	

Measure	Between
This	command	measures	the	distance	or	angle	between	two	elements.

	

1.	 On	the	Measure	toolbar,	click	the	Measure	Between	button.
2.	 Click	on	the	two	elements.	The	distance	between	the	two	elements	will	appear.
3.	 Click	OK.

	

Measure	Item
This	 command	 displays	 the	 physical	 properties	 of	 the	 selected	 element	 based	 on	 the
element	type.	For	example,	if	you	select	a	linear	edge,	it	displays	the	length	of	the	linear
edge.

	

1.	 On	the	Measure	toolbar,	click	the	Measure	Item	button.
2.	 Click	on	an	element	to	display	the	measurements	of	the	element.
3.	 Click	OK.



Measure	Inertia
This	 command	 displays	 the	 physical	 properties	 of	 a	 part	 body	 such	 as	 volume,	 inertia,
mass,	center	of	gravity,	and	so	on.

	

1.	 On	the	Measure	toolbar,	click	the	Measure	Inertia	button.
2.	 Click	on	the	part	body.	The	Measure	Inertia	dialog	appears	showing	the	properties	of

the	body.

	

	

3.	 On	this	dialog,	click	the	Measure	Inertia	2D	button,	if	you	want	to	view	the	properties
in	a	2D	plane.

	



Examples
Example	1
In	this	example,	you	will	create	the	part	shown	below.

1.	 Start	CATIA	V5-6R2015.
2.	 On	the	Menu,	click	File	>	New.
3.	 On	the	New	dialog,	select	List	of	Types	>	Part,	and	then	click	OK.
4.	 On	the	New	Part	dialog,	type-in	C03-Example1,	and	then	click	OK.
5.	 On	the	Sketcher	toolbar,	click	the	Sketch	icon.
6.	 Click	YZ	plane	to	start	the	sketch.
7.	 On	the	Profile	toolbar,	click	Predefined	Profile	>	Rectangle.
8.	 Click	the	origin	point	to	define	the	first	corner	of	the	rectangle.
9.	 Move	the	pointer	toward	top	right	and	click	to	define	the	second	corner.
10.	 Apply	dimensions	to	the	rectangle.

11.	 On	the	Workbench	toolbar,	click	Exit	workbench.
12.	 On	the	Sketch-Based	Features	toolbar,	click	Pads	drop-down	>	Pad.
13.	 On	the	Pad	Definition	dialog,	click	Type	>	Dimension.
14.	 On	the	dialog,	type-in	32.5	in	the	Length	box.
15.	 Check	the	Mirror	extent	option	and	click	OK	to	complete	the	Pad	feature.

	



16.	 On	the	Sketch-Based	Features	toolbar,	click	Pockets	drop-down	>	Pocket.
17.	 On	the	Pocket	Definition	dialog,	under	the	Profile/Surface	section,	click	the	Sketch

icon.
18.	 Click	on	the	front	face	of	the	part	geometry.

19.	 Activate	the	Rectangle	command	and	draw	a	rectangle	touching	the	right	edge	of	the
front	face.

20.	 Apply	constraints	to	it.



21.	 On	the	Workbench	toolbar,	click	Exit	workbench.
22.	 On	the	Pocket	Definition	dialog,	select	Type	>	Up	to	last.
23.	 Click	OK	to	create	the	cut	throughout	the	part	geometry.

24.	 Activate	the	Pocket	command	and	click	the	Sketch	icon	on	the	Pocket	Definition
dialog.

25.	 Click	on	the	top	face	of	the	part	geometry.
26.	 Draw	a	closed	sketch	on	the	top	face.

27.	 On	the	Workbench	toolbar,	click	Exit	workbench.
28.	 On	the	Pocket	Definition	dialog,	click	Type	>	Up	to	n	ext.
29.	 Click	OK	to	create	the	Pocket	feature	until	the	surface	next	to	the	sketch	plane.



30.	 Activate	the	Pad	command	and	click	the	Sketch	icon	on	the	Pad	Definition	dialog.
31.	 Click	on	the	XY	plane.
32.	 Draw	a	closed	sketch.	Apply	dimensions	and	finish	the	sketch.

33.	 On	the	Pad	Definition	dialog,	click	Type	>	Up	to	plane	and	select	the	horizontal	face
of	the	part	geometry,	as	shown	in	figure.

34.	 Click	OK	to	complete	the	part.



35.	 Save	and	close	the	file.

	

Example	2
In	this	example,	you	will	create	the	part	shown	below.

1.	 Start	CATIA	V5-6R2015.
2.	 On	the	Menu,	click	File	>	New.
3.	 On	the	New	dialog,	select	List	of	Types	>	Part,	and	then	click	OK.
4.	 On	the	New	Part	dialog,	type-in	C03-Example2,	and	then	click	OK.
5.	 Draw	a	sketch	on	the	XY	plane,	as	shown	below.

6.	 Exit	the	Sketcher	Workbench.
7.	 On	the	Sketch-Based	Features	toolbar,	click	the	Shaft	 icon.
8.	 Select	the	sketch	and	click	on	the	line	passing	through	the	origin.



9.	 On	the	Shaft	Definition	dialog,	type-in	0	and	180	in	the	First	angle	and	Second	angle
boxes,	respectively.

10.	 Click	OK	to	create	the	Shaft	feature.

11.	 On	the	Sketch-Based	Features	toolbar,	click	the	Groove	icon	(or)	click	Insert	>
Sketch-Based	Features	>	Groove	on	the	Menu.

12.	 On	the	Groove	Definition	dialog,	click	the	Sketch	icon	and	select	the	top	face	of	the
part	geometry.

13.	 Draw	the	sketch	on	top	face	and	apply	dimensions.	Exit	the	sketch.

14.	 Type-in	0	and	180	in	the	First	angle	and	Second	angle	boxes.
15.	 Click	OK	to	create	the	revolved	groove.



16.	 Activate	the	Shaft	command	and	click	the	Sketch	icon	on	the	Shaft	Definition	dialog.
17.	 Click	on	the	top	face	of	the	part	geometry.
18.	 Draw	a	sketch	and	click	Exit	workbench.

19.	 Type-in	the	180	and	0	in	the	First	angle	and	Second	angle	boxes,	respectively.
20.	 Click	OK	to	add	the	Shaft	feature	to	the	geometry.

21.	 Save	and	close	the	file.

	

Questions
1.	 How	do	you	create	parallel	planes	in	CATIA	V5?
2.	 List	any	two-limit	types	available	on	the	Pad	Definition	dialog.
3.	 List	the	commands	to	create	pad	features.
4.	 How	do	you	create	angled	planes	in	CATIA	V5?

	

	

	



Exercises
Exercise	1

	

	

	

	

	

	

	

	

	

	



	
Exercise	2

	
	
	
	
	
	
	
	
	
	
	
	



	
Exercise	3

	

	

	

	

	

	

	

	

	

	

	

	

	

	

	

	



	

	

	





Chapter	4:	Holes	and	Dress-Up	Features
So	for,	all	of	the	features	that	were	covered	in	the	previous	chapter	were	based	on	two-
dimensional	sketches.	However,	there	are	certain	features	in	CATIA	V5	that	do	not	require
a	sketch	at	all.	Features	that	do	not	require	a	sketch	are	called	Dress-Up	features.	You	can
simply	place	them	on	your	models.	However,	you	must	have	some	existing	geometry	to
add	these	features.	Unlike	a	sketch-based	feature,	you	cannot	use	a	Dress-Up	feature	for	a
first	feature	of	a	model.	For	example,	to	create	a	Fillet	feature,	you	must	have	an	already
existing	edge.	In	this	chapter,	you	will	learn	how	to	add	Holes	and	Dress-Up	features	to
your	design.

The	topics	covered	in	this	chapter	are:

	

Holes
Threads
Fillets
Chamfers
Drafts
Shells

	

	Hole
As	you	know,	it	is	possible	to	use	the	Pocket	command	to	create	cuts	and	remove	material.
But,	if	you	want	to	drill	holes	that	are	of	standard	sizes,	the	Hole	command	is	a	better	way
to	do	this.	The	reason	for	this	is	it	has	many	hole	types	already	predefined	for	you.	All	you
have	to	do	is	choose	the	correct	hole	type	and	size.	The	other	benefit	is	when	you	are
going	to	create	a	2D	drawing,	CATIA	V5	can	automatically	place	the	correct	hole
annotation.	Activate	this	command	(On	the	Sketch	Based	Features	toolbar,	click	the
Hole	icon)	and	click	on	a	face	to	a	add	hole.	You	will	notice	that	a	dialog	pops	up.	There
are	options	in	this	dialog	that	make	it	easy	to	create	different	types	of	holes.



	

Simple	Hole
1.	 To	create	a	simple	hole	feature,	select	Type	>	Simple	on	the	Hole	Definition	dialog.

	

	

2.	 Under	the	Extension	tab,	type-in	a	value	in	the	Diameter	box	and	select	the	extension
type.

3.	 If	you	want	a	through	hole,	click	Extension	drop-down	>	Up	To	Last.	If	you	want	a
blind	hole,	then	select	Blind	from	the	Extension	drop-down.	Next,	type-in	a	value	in
the	Depth	box.

4.	 If	you	want	a	V-bottom	hole,	then	select	Bottom	>	V-Bottom	and	type-in	a	value	in
the	Angle	box.

	

5.	 On	the	dialog,	click	Positioned	Sketch,	to	activate	the	Sketcher	Workbench.
6.	 Add	dimensions	to	define	the	hole	position.



7.	 On	the	Workbench	toolbar,	click	the	Exit	Workbench	icon.

	

The	hole	will	be	created	normal	to	the	selected	face.

8.	 If	you	want	to	create	holes	at	an	angle	or	along	a	reference	line,	then	uncheck	the
Normal	to	Surface	option	and	select	a	reference	line	or	edge.	The	hole	will	be	create
along	the	selected	line	or	edge.

	

9.	 Click	OK	to	create	the	holes.

	



Counterbored	Hole
A	counterbore	hole	is	a	large	diameter	hole	added	at	the	opening	of	another	hole.	It	is	used
to	accommodate	a	fastener	below	the	level	of	work	piece	surface.

	

1.	 To	create	a	counterbore	hole,	select	Type>	Counterbored	from	the	dialog.
2.	 Next,	define	the	counterbore	diameter	and	counterbore	depth.

	

	

3.	 Click	the	Extension	tab	and	type-in	values	in	the	Diameter	and	the	Depth	boxes.
4.	 Click	the	icon	next	to	the	Diameter	box,	if	you	want	to	specify	the	hole	tolerances.	On

the	Limit	of	Size	Definition	dialog,	you	can	specify	the	tolerances	using	General
Tolerance,	Numerical	values,	Tabulated	values,	Single	Limit,	or	Information.	Click
OK	after	specifying	the	tolerances.

5.	 If	you	want	a	V-bottomed	counterbore	hole,	then	select	Bottom	>	V-Bottom	and	type-
in	a	value	in	the	Angle	box.

6.	 Position	the	hole	using	the	Positioned	sketch	icon.



You	can	also	create	a	standard	counterbored	hole	using	the	Hole	Standard	drop-down.
You	can	select	Metric_cap_screws	or	Socket_Head_Cap_Screws	hole	standard.	Next,
select	the	hole	size	from	the	drop-down	available	below	the	Hole	Standard	drop-down.

	

Countersunk	Hole
A	countersunk	hole	has	an	enlarged	V-shaped	opening	to	accommodate	a	fastener	below
the	level	of	work	piece	surface.

	

1.	 To	create	a	countersunk	hole,	select	Type	>	Countersunk.
2.	 Under	the	Parameters	section,	select	Mode	>	Depth	&	Angle	or	Depth	&	Diameter

or	Angle	&	Diameter.	For	example,	if	you	select	Angle	&	Diameter,	you	must
specify	the	Countersink	diameter	and	angle.

3.	 Type-in	values	in	the	Parameters	section.

	

	

7.	 Click	the	Extension	tab,	specify	the	diameter,	depth,	and	end	condition	of	the	hole.
8.	 Position	the	hole	using	the	Positioned	sketch	icon.



Tapered	Hole
Tapering	is	the	process	of	decreasing	the	hole	diameter	toward	one	end.	A	tapered	hole	has
a	smaller	diameter	at	the	bottom.

	

1.	 To	create	a	tapered	hole,	select	Type	>	Tapered	on	the	Hole	Definition	dialog.
2.	 Type-in	the	taper	angle	value	in	the	Angle	box.
3.	 Select	the	Anchor	Point	to	define	the	bottom	or	top	diameter.

	

	

4.	 Specify	the	Extension	parameters	and	hole	position.

	



Threaded	Hole
1.	 To	create	a	threaded	hole	feature,	click	the	Thread	Definition	tab	on	the	Hole

Definition	dialog.

	

2.	 Check	the	Threaded	option	on	the	dialog.
3.	 Under	the	Bottom	Type	section,	select	the	type	of	end	condition.	You	can	select

Dimension,	Support	Depth,	or	Up-To-Plane.	If	you	select	Dimension,	then	you	have
to	type-in	the	thread	depth.	The	Support	Depth	option	creates	the	thread	throughout
the	hole.	The	Up-To-Plane	option	creates	the	thread	up	to	a	plane.

4.	 Under	the	Thread	Definition	section,	select	the	type	of	the	thread.	You	can	select
standard	or	non-standard	threads.	If	you	select	standard	threads,	then	you	have	to	select
the	thread	size	from	the	Thread	Description	menu.	All	thread	size	and	pitches	will	be
calculated,	automatically.	If	you	select	No	Standard	thread,	then	you	have	to	type-in
the	thread	diameter,	hole	diameter,	and	pitch.

5.	 Define	the	thread	direction	by	select	the	Right-Threaded	or	Left-Threaded	option.

	

The	Thread/Tap	command
This	command	adds	a	thread/tap	feature	to	a	cylindrical	face.	A	thread	is	added	to	the
outer	cylindrical	face,	whereas	a	tap	is	added	to	the	inner	cylindrical	face	(holes).	You	add
thread/tap	features	to	a	3D	geometry	so	that	when	you	create	a	2D	drawing,	CATIA	V5
can	automatically	place	the	correct	thread	annotation.

	

1.	 On	the	Dress-Up	Features	toolbar,	click	the	Thread/Tap	button	(or)	click	Insert	>
Dress-Up	Features	>	Thread/Tap	on	the	Menu	bar.	The	Thread/Tap	Definition
dialog	pops	up	on	the	screen.

2.	 To	create	a	thread,	select	the	Thread	option	and	click	on	the	outer	cylindrical	face	of
the	part	geometry.



3.	 Click	on	the	end	face	of	the	cylindrical	feature	to	define	the	limiting	face.
4.	 Under	the	Numerical	Definition	section,	select	the	thread	type	from	the	Type	menu.

You	can	select	a	standard	or	non-standard	thread	type.	In	case	of	standard	threads,	the
diameter	of	the	cylinder	should	match	any	standard	thread	format.

5.	 For	non-standard	threads,	type-in	the	thread	diameter,	thread	depth,	and	pitch	values.
6.	 Define	the	thread	direction	and	click	OK.

	

The	Edge	Fillet	command
This	command	breaks	the	sharp	edges	of	a	model	and	blends	them.	You	do	not	need	a
sketch	to	create	a	fillet.	All	you	need	to	have	is	model	edges.

	

1.	 On	the	Dress-Up	Features	toolbar,	click	the	Edge	Fillet	button	(or)	click	Insert	>
Dress-Up	Features	>	Edge	Fillet	on	the	Menu	bar.	The	Edge	Fillet	Definition	dialog
pops	up	on	the	screen.

2.	 Select	the	edges	to	fillet.	You	can	also	select	all	the	edges	of	a	face	by	simply	clicking
on	the	face.	By	mistake,	if	you	have	selected	a	wrong	edge	you	can	deselect	it	by
selecting	the	edge	again.

3.	 You	can	change	the	radius	by	typing	a	value	in	the	Radius	box	available	on	the	Edge
Fillet	Definition	dialog.	As	you	change	the	radius,	all	the	selected	edges	will	be
updated.	This	is	because	they	are	all	part	of	one	instance.	If	you	want	the	edges	to	have
different	radii,	you	must	create	rounds	in	separate	instances.	Select	the	required	number
of	edges	and	click	OK	to	finish	this	feature.	The	Edge	Fillet	feature	will	be	listed	in	the
Specification	Tree.



If	you	want	to	select	all	the	edges	that	are	tangentially	connected,	then	select	Propagation
>	Tangency	on	the	dialog.

If	you	select	Propagation	>	Minimal	on	the	dialog,	the	selected	will	be	filleted	ignoring
the	connected	ones.

If	 you	 select	Propagation	>	 Intersection,	 then	 you	 can	 fillet	 the	 intersections	 between
two	features	of	the	geometry.

Select	 Propagation	 >	 Intersection	 with	 selected	 features	 to	 fillet	 the	 intersections
between	the	selected	features	only.



	

Conic	fillets
By	default,	 the	edge	 fillets	have	a	circular	arc	profile.	However,	 if	you	want	 to	create	a
fillet	with	conical	arc	profile,	then	check	the	Conic	parameter	option	on	the	dialog.	Next,
type-in	a	value	 in	 the	Conic	parameter	box.	The	fillets	with	different	conic	parameters
are	shown	below.

Trim	ribbons
If	 you	 are	 creating	 fillets,	which	 intersect	 each	 other,	 then	 you	need	 to	 check	 the	Trim
ribbons	option.	This	trims	the	intersecting	portion.

Edge(s)	to	keep
If	 you	 create	 fillets,	which	 intersect	with	 the	 adjacent	 edges,	 then	 this	may	 deform	 the
edges.



To	 avoid	 this,	 click	 the	More	 button	 on	 the	 dialog	 and	 click	 in	 the	 Edge(s)	 to	 keep
selection	box.	Now,	select	the	adjacent	edges.

Limiting	element(s)
If	you	want	to	create	an	edge	fillet	only	up	to	some	distance,	then	expand	the	Edge	Fillet
Definition	dialog	and	click	in	the	Limiting	element(s)	selection	box.	Click	on	a	reference
element	(plane	or	point)	to	define	the	limiting	elements.	If	there	is	no	reference	element
available,	then	click	the	right	mouse	button	in	the	Limiting	element(s)	selection	box	and
create	one.



Blend	corner(s)
If	you	create	an	edge	fillet	on	three	edges	that	come	together	at	a	corner,	you	have	the
option	to	control	how	these	three	fillets	are	blend	together.	Activate	the	Edge	Blend
command	and	select	the	three	edges	that	meet	together	at	a	corner.	On	the	Edge	Fillet
Definition	dialog,	click	the	right	mouse	button	in	the	Blend	corner(s)	selection	box,	and
then	select	Create	by	edges.	If	you	select	Create	by	edges,	then	the	corner	point	will	be
selected,	automatically.	You	can	also	select	the	vertex	where	the	three	fillets	meet.	You
will	notice	that	three	setback	distances	appear	at	the	corner.

	

Double-click	on	the	setback	distances	and	type-in	values	in	the	Parameter	Definition
boxes.

	

	Variable	Radius	Fillet
CATIA	V5	allows	you	to	create	a	fillet	with	a	varying	radius	along	the	selected	edge.



	

1.	 On	the	Dress-Up	Features	toolbar,	click	Fillets	drop-down	>	Edge	Fillet	(or)	click
Insert	>	Dress-Up	Features	>	Edge	Fillet	on	the	Menu	bar.

2.	 On	the	Edge	Fillet	Definition	dialog,	click	the	Variable	icon.
3.	 Click	on	the	edge	to	fillet.
4.	 Click	in	the	Points	selection	box	to	select	variable	radius	points.
5.	 On	the	selected	edge,	select	points	to	define	variable	radius.	You	will	notice	that	radius

values	appear	on	the	selected	points.

6.	 Double-click	on	the	radius	values	that	appear	on	the	selected	points.	The	Parameter
Definition	box	appears.

7.	 Type-in	a	value	in	the	Parameter	Definition	box	and	click	OK.	You	can	also	modify
the	radii	by	clicking	the	button	 next	to	the	Radius	box.	This	displays	the	Fillet
values	dialog.	On	this	dialog,	click	on	different	points	and	change	the	radius	values.
Click	OK	to	close	the	Fillet	values	dialog.

8.	 Click	Preview	to	see	how	the	variable	radius	fillet	would	look.
9.	 On	the	dialog,	click	Variation	>	Cubic	to	get	a	smooth	fillet.	Click	Variation	>

Linear	to	get	a	straight	transition	fillet.



10.	 Click	OK	to	create	the	variable	radius	fillet.

	

Chordal	Fillet
This	option	helps	you	to	create	a	fillet	by	specifying	its	chord	length	instead	of	a	radius.
The	chord	length	is	the	distance	between	the	endpoints	of	the	fillet	profile.

	
1.	 On	the	Dress-Up	Features	toolbar,	click	Fillets	drop-down	>	Edge	Fillet	(or)	click

Insert	>	Dress-Up	Features	>	Edge	Fillet	on	the	Menu	bar.
2.	 On	the	Edge	Fillet	Definition	dialog,	click	the	Chordal	Length	icon	available	next	to

the	Radius	box.
3.	 Click	on	the	edge	to	fillet.
4.	 Type-in	a	value	in	the	Chordal	Length	box.
5.	 If	 you	want	 to	 create	 a	variable	 radius	 fillet,	 then	click	 the	Variable	 icon	 and	 select

multiple	points	on	the	edge.	Change	the	chordal	length	values	of	the	points.

	

Face-Face	Fillet
This	command	creates	a	fillet	between	two	faces.	The	faces	are	not	required	to	be
connected	with	each	other.

	

1.	 On	the	Dress-Up	Features	toolbar,	click	Fillets	drop-down	>	Face-Face	Fillet	(or)
click	Insert	>	Dress-Up	Features	>	Face-Face	Fillet	on	the	Menu	bar.

2.	 Click	on	two	faces.



3.	 Type-in	a	value	in	the	Radius	box.
4.	 Click	OK.

Tritangent	Fillet
This	command	creates	a	fillet	between	three	faces.	It	replaces	the	middle	face	with	a	fillet.

	

1.	 On	the	Dress-Up	Features	toolbar,	click	Fillets	drop-down	>	Tritangent	Fillet	(or)
click	Insert	>	Dress-Up	Features	>	Tritangent	Fillet	on	the	Menu	bar.

2.	 Click	on	three	faces	of	the	model	geometry.
3.	 Click	OK	to	replace	the	middle	face	with	a	fillet.

	



The	Chamfer	command
The	Chamfer	and	Edge	Fillet	commands	are	commonly	used	to	break	sharp	edges.	The
difference	is	that	the	Chamfer	command	adds	a	bevel	face	to	the	model.	A	chamfer	is	also
a	placed	feature.

	

1.	 On	the	Dress-Up	Features	toolbar,	click	the	Chamfer	button	(or)	click	Insert	>
Dress-Up	Features	>	Chamfer	on	the	Menu	bar.

2.	 On	the	Chamfer	Definition	dialog,	select	chamfer	Mode.	You	can	select
Length1/Angle,	Length1/Length2,	Chordal	Length/Angle,	or	Height/Angle.

	

	

3.	 If	you	select	Mode	>	Length1/Angle,	then	type-in	the	length	and	angle	values	of	the
chamfer.

4.	 Click	on	the	edge(s)	to	chamfer.



5.	 Click	OK.

	

Draft	Angle
When	creating	cast	or	plastic	parts,	you	are	often	required	to	add	draft	on	them	so	that
they	can	be	molded.	A	draft	is	an	angle	or	taper	applied	to	the	faces	of	parts	to	make	it
easier	to	remove	them	from	a	mold.	When	creating	Drafted	Filleted	Pad	features,	you	can
predefine	the	draft	angle.	However,	most	of	the	time,	it	is	easier	to	apply	the	draft	after	the
features	are	created.

	

1.	 On	the	Dress-Up	Features	toolbar,	click	Drafts	drop-down	>	Draft	Angle	(or)	click
Insert	>	Dress-Up	Features	>	Draft	on	the	Menu	bar.

2.	 On	the	Draft	Definition	dialog,	select	Draft	Type	>	Constant.
3.	 Click	on	the	faces	to	draft.
4.	 Under	the	Neutral	Element	section,	click	in	the	Selection	box	and	select	a	flat	face	or

plane.	This	defines	the	neutral	plane.	The	draft	angle	will	be	measured	with	reference
to	this	face.

5.	 Type-in	a	value	in	the	Angle	box.	This	defines	the	draft	angle.
6.	 Click	Preview.



7.	 If	you	want	to	reverse	the	draft	direction,	then	click	the	arrow	that	appears	on	the
geometry.

8.	 Click	OK	to	apply	draft.

Parting=Neutral
If	you	want	to	add	draft	only	up	to	a	certain	height,	then	create	a	plane	at	that	height.
Activate	the	Draft	Angle	command	and	select	the	faces	to	draft.	Click	in	the	Neutral
Plane	selection	box	and	select	the	plane.	On	the	dialog,	click	the	More	button	and	check
the	Parting=Neutral	option.

If	you	check	 the	Draft	both	sides	 option,	 the	draft	will	be	applied	on	both	 sides	of	 the
parting	plane.



Draft	Reflect	Line
This	command	creates	a	draft	by	using	the	silhouette	edges	(reflected	lines)	of	the	curved
feature.

	

1.	 On	the	Dress-Up	Features	toolbar,	click	Drafts	drop-down	>	Draft	Reflect	line	(or)
click	Insert	>	Dress-Up	Features	>	Draft	reflect	line	on	the	Menu	bar.

2.	 Select	a	curved	face	to	define	the	drafting	face.
3.	 Click	in	the	Pulling	Direction	selection	box	and	select	a	flat	face	or	plane.	This	defines

the	pulling	direction.
4.	 Click	the	More	button	on	the	dialog	and	check	the	Define	parting	element	option.
5.	 Select	a	flat	face	or	plane	to	define	the	parting	element.

6.	 Type-in	a	value	in	the	Angle	box,	and	then	click	OK.

Variable	Angle	Draft
This	command	creates	a	variable	angle	draft.

	

1.	 On	the	Dress-Up	Features	toolbar,	click	Drafts	drop-down	>	Variable	Angle	Draft
(or)	click	Insert	>	Dress-Up	Features	>	Variable	Angle	Draft	on	the	Menu	bar.

2.	 Click	on	the	face	to	draft.	If	you	select	multiple	faces,	you	have	to	make	sure	that	they
are	connected,	tangentially.

3.	 Click	in	the	Neutral	element	box	and	select	a	flat	face	or	plane.
4.	 Click	in	the	Points	box	and	select	multiple	points	to	define	different	angles.	You	will



notice	that	angle	values	appear	on	the	selected	points.
5.	 Double-click	on	the	angle	values	to	change	them.

6.	 Click	OK.

	

Shell
The	Shell	is	another	useful	feature	that	can	be	applied	directly	to	a	solid	model.	It	allows
you	to	take	a	solid	geometry	and	make	it	hollow.	This	can	be	a	powerful	and	timesaving
technique,	when	designing	parts	that	call	for	thin	walls	such	as	bottles,	tanks,	and
containers.	This	command	is	easy	to	use.

	

1.	 You	should	have	a	solid	part,	and	then	activate	this	command	from	the	Dress-Up
Features	toolbar	(or)	click	Insert	>	Dress-Up	Features	>	Shell	on	the	Menu	bar.

2.	 Select	the	faces	to	remove.
3.	 Type-in	the	wall	thickness	in	the	Default	inside	thickness	box.
4.	 If	 you	 want	 to	 add	 outside	 thickness,	 then	 type-in	 a	 value	 in	 the	 Default	 inside

thickness	box.
5.	 If	you	want	add	different	 thickness	 to	some	faces,	 then	click	 in	 the	Other	thickness

faces	box,	and	 then	select	 the	 faces	 to	add	different	 thickness.	You	will	notice	 that	a
thickness	value	appears	on	the	selected	face.	Double-click	on	the	value	and	change	it.



6.	 Click	OK	to	finish	the	feature.

If	 you	want	 to	 shell	 the	 solid	 body	without	 removing	 any	 faces,	 then	 simply	 type-in	 a
value	 in	 the	Default	 inner	 thickness	 box	 and	 click	OK.	 This	 creates	 the	 shell	without
removing	the	faces.	Change	the	Render	style	to	Wireframe	or	Shading	with	Edges	and
Hidden	Edges	to	view	the	shell.

	

	

	



Examples
Example	1
In	this	example,	you	will	create	the	part	shown	next.

	

	

	

1.	 Start	CATIA	V5-6R2015.
2.	 On	the	Standard	toolbar,	click	New.	On	the	New	dialog,	select	List	of	Types	>

Parts.	Click	OK.
3.	 On	the	New	Part	dialog,	type-in	C04-Example1	and	check	the	Enable	hybrid

design	option.	Click	OK.
4.	 On	the	Sketch	Based	Features	toolbar,	click	the	Pad	 icon.
5.	 On	the	Pad	Definition	dialog,	click	the	Sketch	 icon	and	select	the	YZ	plane.

Draw	the	sketch	shown	in	figure	and	create	the	pad	feature	of	64	mm	thickness.



6.	 On	 the	Sketcher	 toolbar,	 click	 the	Sketch	 icon,	 and	 then	 select	 the	 right-side
face.

7.	 On	the	Profile	toolbar,	click	Points	drop-down	>	Point	by	clicking	 and	place	a
point.

8.	 Add	dimensions	to	locate	the	point.

9.	 Click	Exit	Workbench .



10.	 On	the	Sketch	Based	Features	toolbar,	click	the	Hole	 icon	and	select	the	sketch
point.

11.	 Click	on	the	right-side	face.
12.	 On	the	Hole	Definition	dialog,	select	Extension	>	Up	to	Last.
13.	 Type-in	20	in	the	Diameter	box.
14.	 Click	the	Type	tab	and	Countersunk	from	the	drop-down.
15.	 Under	the	Parameters	section,	select	Mode	>	Angle	&	Diameter.
16.	 Set	the	Angle	and	Diameter	values	to	82	and	24,	respectively.

	

	

17.	 Click	OK	to	complete	the	hole	feature.

18.	 Activate	the	Hole	 command	and	click	on	the	top	face	of	the	part	geometry.
19.	 On	the	Hole	Definition	dialog,	click	the	Positioned	Sketch	 icon	to	activate	the

Sketcher	Workbench.
20.	 Add	dimensions	to	the	sketch	point	and	exit	the	Sketcher	Workbench.



21.	 On	the	Hole	Definition	dialog,	click	the	Type	tab	and	select	Simple	from	the	drop-
down.

22.	 Click	OK	to	close	the	dialog.

23.	 On	the	top-right	corner	of	the	graphic	window,	double-click	the	Z-axis	of	the
Compass.

24.	 On	the	Parameters	for	Compass	Manipulation	dialog,	type-in	90	in	the	Rotation
Increment	box	along	the	W	axis.

25.	 Click	the	rotation	in	positive	direction	button.	Click	Close	to	close	the	dialog.

	



	

26.	 On	the	View	toolbar,	click	the	Fit	All	In	 icon	to	fit	the	geometry	in	the	graphics
window.

27.	 Activate	the	Sketch	 	command	and	click	on	the	lower	top	face	of	the	model
geometry.

28.	 Activate	the	Points	by	clicking	command	and	place	two	points.
29.	 Add	dimensions	to	position	the	points.

30.	 Exit	the	Sketcher	Workbench.
31.	 Activate	the	Hole	command	and	select	anyone	of	the	sketch	points.
32.	 Click	on	the	lower	top	face	of	the	model	geometry.
33.	 On	the	Hole	Definition	dialog,	select	Extension	>	Up	To	Last.
34.	 Type-in	10	in	the	Diameter	box	and	click	OK.
35.	 Create	another	hole	using	the	remaining	sketch	point.

Chamfer	Edges
1.	 On	the	Dress-Up	Features	toolbar,	click	the	Chamfer	icon	(or)	click	Insert	>	Dress-

Up	Features	>	Chamfer.
2.	 On	the	Chamfer	Definition	dialog,	select	Mode	>	Length1/Length2.
3.	 Set	the	Length1	and	Length	2	values	to	20	and	10,	respectively.



4.	 Click	on	the	side	vertical	edges,	as	shown	in	figure.

5.	 Click	OK	to	apply	chamfers.

6.	 On	 the	Dress-Up	Features	 toolbar,	 click	 the	Edge	Fillet	 icon	 (or)	 click	 Insert	 >
Dress-Up	Features	>	Edge	Fillet.

7.	 On	the	Edge	Fillet	Definition	dialog,	type-in	8	in	the	Radius	box.
8.	 On	the	View	toolbar,	click	View	Mode	drop-down	>	Wireframe	(NHR) .
9.	 Click	on	the	horizontal	edges	of	the	geometry,	as	shown	below.

10.	 Click	OK	to	add	edge	fillets.
11.	 Activate	the	Edge	Fillet	 command	and	type-in	20	in	the	Radius	box.
12.	 Click	on	the	outer	edges	of	the	model,	as	shown	below.	Click	OK	to	complete	the	edge

fillet	feature.



13.	 On	the	View	toolbar,	click	View	Mode	drop-down	>	Shading	with	Edges .

14.	 On	the	View	toolbar,	click	Quick	View	Drop-down	>	Isometric	View 	to	change
the	orientation	of	the	model	view	to	Isometric.

15.	 On	the	Dress-Up	Features	toolbar,	click	the	Chamfer	 icon	(or)	click	Insert	>
Dress-Up	Features	>	Chamfer.

16.	 On	the	Chamfer	Definition	dialog,	select	Mode	>	Length1/Angle.
17.	 Click	on	the	lower	corners	of	the	part	geometry.

18.	 Type-in	10	and	45	in	the	Length	and	Angle	boxes,	respectively.	Click	OK	to	chamfer
the	edges.



19.	 Save	and	close	the	file.

	

	

	

	

	
	
Questions
1.	 What	are	Dress-Up	features?
2.	 Which	option	allows	you	to	create	a	chamfer	with	unequal	setbacks?
3.	 Which	option	allows	you	create	a	variable	radius	blend?
4.	 When	you	create	a	thread	on	a	cylindrical	face,	the	thread	diameter	will	be	calculated

automatically	or	not?

	

Exercises
Exercise	1



	

Exercise	2

	





Chapter	5:	Patterned	Geometry

When	designing	a	part	geometry,	oftentimes	there	are	elements	of	symmetry	in	each	part
or	 there	 are	 at	 least	 a	 few	 features	 that	 are	 repeated	multiple	 times.	 In	 these	 situations,
CATIA	V5	 offers	 you	 some	 commands	 that	 save	 your	 time.	 For	 example,	 you	 can	 use
mirror	features	to	design	symmetric	parts,	which	makes	designing	the	part	quicker.	This	is
because	you	only	have	to	design	a	portion	of	the	part	and	use	the	mirror	feature	to	create
the	remaining	geometry.

	

	

	

In	addition,	there	are	some	transformation	commands	to	replicate	a	feature	throughout	a
part	quickly.	They	save	you	time	from	creating	additional	features	individually	and	help
you	to	modify	the	design	easily.	If	the	design	changes,	you	only	need	to	change	the	first
feature	and	the	rest	of	the	pattern	features	will	update,	automatically.	In	this	chapter,	you
will	learn	to	create	mirrored	and	pattern	geometries	using	the	commands	available	in
CATIA	V5.



	

The	topics	covered	in	this	chapter	are:

	

Mirror	features
Rectangular	Patterns
Circular	Patterns
User	Patterns
Fill	Patterns

	

	The	Mirror	command
If	 you	 are	 designing	 a	 part	 that	 is	 symmetric,	 you	 can	 save	 time	 by	 using	 the	Mirror
Feature	 command.	 Using	 this	 command,	 you	 can	 replicate	 individual	 features	 of	 the
entire	body.	To	mirror	features	(3D	geometry),	you	need	to	have	a	face	or	plane	to	use	as	a
mirroring	element.	You	can	use	a	model	 face,	default	plane,	or	create	a	new	plane,	 if	 it
does	not	exist	where	it	is	needed.

	

1.	 On	the	Transformation	Features	toolbar,	click	the	Mirror	button	(or)	click	Insert	>
Transformation	Features	>	Mirror	on	the	Menu	bar.

2.	 Select	the	reference	plane	about	which	the	features	are	to	be	mirrored.
3.	 Click	in	the	Object	to	mirror	box	and	click	on	the	features	to	mirror.



4.	 Click	OK.

Now,	if	you	make	changes	to	original	feature,	the	mirror	feature	will	be	updated
automatically.

If	the	part	you	are	creating	is	completely	symmetric,	you	can	save	more	time	by	creating
half	of	it	and	mirroring	the	entire	geometry	rather	than	individual	features.	Activate	the
Mirror	command	and	click	on	the	mirror	element.	As	the	solid	body	is	selected	by
default,	you	just	need	to	click	OK	to	mirror	the	complete	body.



	Rectangular	Pattern
This	command	replicates	a	feature	using	a	rectangular	layout.

	

1.	 On	the	Transformation	Features	toolbar,	click	Patterns	drop-down	>	Rectangular
Pattern	(or)	click	Insert	>	Transformation	Features	>	Rectangular	Pattern	on	the
Menu	bar.

2.	 On	the	Rectangular	Pattern	Definition	dialog,	click	in	the	Object	box	and	select	the
object	to	pattern.

3.	 Click	in	the	Reference	element	box	and	click	on	an	edge	to	define	the	first	direction	of
the	rectangular	pattern.	You	will	notice	that	a	pattern	preview	appears	on	the	model.

4.	 Now,	select	Parameters	>	Instance(s)	&	Spacing	on	the	dialog	and	set	the	parameters
of	the	pattern	(Instance(s)	and	Spacing).

5.	 Click	the	Reverse	button,	if	you	want	to	reverse	the	pattern	direction.

	

	

6.	 Click	the	Second	Direction	tab	on	the	dialog.
7.	 Click	in	the	Reference	element	box	and	click	on	an	edge	to	define	the	second	direction

of	the	pattern.



8.	 Set	the	parameters	(Instance(s)	and	Spacing)	of	pattern	in	the	second	direction.
9.	 Click	the	Reverse	button,	if	you	want	to	reverse	the	pattern	direction.

10.	 Click	Preview.

If	you	want	to	suppress	an	instance	of	the	pattern,	then	click	on	the	orange	dot	on	it.	This
suppresses	the	instance.	If	you	want	to	unsuppress	the	instance,	then	click	the	orange	dot
again.

	



	

	

Select	Parameters	>	Instance(s)	&	Length	on	the	Rectangular	Pattern	Definition
dialog,	if	you	want	to	enter	instance(s)	and	total	length	along	the	direction	1	or	direction	2.

	

	

Select	 Parameters	 >	 Spacing	 &	 Length,	 if	 you	 want	 to	 enter	 the	 distance	 between
individual	instances	of	the	pattern	and	total	length	along	the	directions.

	

	

Select	Parameters	>	Instance(s)	&	Unequal	Spacing	to	define	different	spacing	values
for	 each	 instance.	You	will	 notice	 that	 individual	 spacing	 values	 appear	 on	 the	 pattern.
Double-click	on	these	values	and	change	them.

	

	

If	you	want	to	create	a	square	pattern,	then	check	Identical	instances	in	both	directions



under	the	Square	Pattern	section.

	

Keep	Specifications
This	option	creates	the	rectangular	pattern	by	keeping	the	specifications	of	the	original
feature.	For	example,	if	the	original	feature	of	pattern	is	created	by	extruding	up	to	an
irregular	surface,	then	the	Keep	Specifications	option	creates	all	the	features	of	the
rectangular	pattern	by	maintaining	the	extrusion	condition.

	

	

	

	
Patterning	the	entire	geometry
Patterning	the	entire	geometry	of	a	part	is	easier	than	patterning	features.	You	need	to



activate	the	Rectangular	Pattern	command	and	define	the	direction,	instant	count,	and
spacing	between	the	instances.	There	is	no	need	to	select	the	geometry	as	it	is	selected	by
default.

	

Position	of	Object	in	Pattern
On	the	Rectangular	Pattern	Definition	dialog,	there	is	an	option	to	change	the	position
of	the	original	feature/body.	Expand	the	Rectangular	Pattern	Definition	dialog	type-in
values	in	Row	in	direction	1	and	Row	in	direction	2	boxes.	The	position	of	the	origin
feature/body	changes.

	

	



	

	

You	can	also	change	the	angular	position	of	the	pattern	feature/body	by	typing-in	a	value
in	the	Rotation	angle	box.

	



	

Staggered	Pattern	Definition
The	Rectangular	Pattern	command	has	an	option	to	create	staggered	pattern.	In	a
staggered	pattern,	the	position	of	one	row	is	offset	from	another.

	

	

1.	 To	create	this	kind	of	pattern,	you	need	to	activate	the	Rectangular	Pattern	command
and	select	the	feature	to	pattern.

2.	 Define	the	pattern	parameters	in	two	directions	(make	sure	that	there	are	more	than	two
instances	in	both	the	directions).

3.	 Expand	the	Rectangular	Pattern	Definition	dialog	and	check	the	Staggered	option.
4.	 Type-in	 the	offset	value	 in	 the	Stagger	Step	box	 (or)	 check	 the	Set	half	 of	 spacing

option.
5.	 Click	anyone	of	the	two	buttons	available	in	the	Staggered	Pattern	Definition	section.
6.	 Click	OK	to	create	the	staggered	pattern.



	

Circular	Pattern
This	command	patterns	the	selected	features	in	a	circular	fashion.

	

1.	 On	 the	 Transformation	 Features	 toolbar,	 click	 Patterns	 drop-down	 >	 Circular
Pattern	 (or)	 click	 Insert	 >	 Transformation	 Features	 >	 Circular	 Pattern	 on	 the
Menu	bar.

2.	 Click	in	the	Object	box	and	select	the	feature	to	pattern	from	the	model	geometry.
3.	 Click	in	the	Reference	element	box	and	select	an	axis,	edge,	plane,	or	cylindrical	face.

This	defines	the	axis	of	circular	pattern.
4.	 Select	Parameters	>	Complete	Crown.
5.	 Type-in	a	value	in	the	Instance(s)	box.

	

	

	

Select	Parameters	>	Instance(s)	&	angular	spacing,	if	you	want	to	type-in	the	instance
count	and	the	angle	between	individual	instances.

	



	

	

Select	Parameters	>	Instance(s)	&	total	angle,	if	you	want	to	type-in	the	instance	count
and	total	angle.	The	angle	between	the	instances	will	be	calculated,	automatically.	For
example,	enter	5	in	the	Instance(s)	box	and	300	in	the	Total	angle	box.	This	creates	five
instances	including	the	original	one.	The	angle	between	the	instances	will	be	60	(300/5).
However,	if	you	enter	6	and	360	in	the	Instance(s)	and	Total	angle	boxes,	an	error
appears	showing	that	one	or	more	instances	overlap	each	other.

	

	

	

Select	Parameters	>	Angular	 spacing	&	 total	 angle,	 if	 you	want	 to	 type-in	 the	 angle
between	individual	instances	and	the	total	angle	of	the	circular	pattern.

	



	

Select	Parameters	>	Instance(s)	&	unequal	angular	spacing,	if	you	want	to	define
different	angular	spacing	for	each	instance.	You	will	notice	that	the	individual	spacing
values	appear	on	the	pattern.	Double-click	on	these	values	and	change	them.

	

	

	

Under	the	Rotation	of	Instance(s)	section,	uncheck	Radial	alignment	of	instance(s)	to
pattern	the	feature	with	the	original	orientation.

	

Check	this	option	to	change	the	orientation	of	the	instances,	as	they	are	patterned	in	the
circular	fashion.

	

	

Crown	Definition
The	Circular	Pattern	command	has	options	to	radiate	the	circular	pattern.	

	

1.	 On	 the	Circular	Pattern	Definition	 dialog,	 click	 the	Crown	Definition	 tab	 to	 view
the	options	to	radiate	the	circular	pattern.



2.	 Select	Parameters	>	Circle(s)	&	circle	spacing.
3.	 Type-in	values	in	the	Circle(s)	and	Circle	spacing	boxes.

	

User	Pattern
This	command	patterns	the	selected	features	by	using	user-defined	points.

	

1.	 On	the	Transformation	Features	 toolbar,	click	Patterns	drop-down	>	User	Pattern
(or)	click	Insert	>	Transformation	Features	>	User	Pattern	on	the	Menu	bar.

2.	 On	the	User	Defined	Pattern	Definition	dialog,	click	in	the	Object	box	and	select	the
feature	to	pattern.

3.	 Click	in	the	Anchor	box	and	select	a	point	to	define	the	origin	point	of	the	pattern.
4.	 Click	on	individual	points	(or)	the	sketch	containing	points.

5.	 Click	OK	to	create	the	pattern.



Scaling
This	command	scales	the	part	geometry	with	reference	to	the	face,	point,	or	plane.

	

1.	 On	the	Transformation	Features	toolbar,	click	Scale	drop-down	>	Scaling	(or)	click
Insert	>	Transformation	Features	>	Scaling	on	the	Menu	bar.

2.	 Click	on	the	face	or	plane	to	define	the	scaling	direction.
3.	 Type-in	the	scaling	factor	in	the	Ratio	box.

4.	 Click	OK	to	scale	the	body.

	

Affinity
This	command	scales	the	part	geometry	along	three	directions	using	the	coordinate	values
that	you	specify.

	

1.	 On	the	Transformation	Features	toolbar,	click	Scale	drop-down	>	Affinity	(or)	click
Insert	>	Transformation	Features	>	Affinity	on	the	Menu	bar.

2.	 On	the	Affinity	Definition	dialog,	type-in	values	in	the	X,	Y,	Z	boxes.

	



	

3.	 Click	OK.

	



Examples
Example	1

In	this	example,	you	will	create	the	part	shown	next.

.

.

	

	

1.	 Start	CATIA	V5-6R2015.
2.	 Open	a	new	part	file.
3.	 Activate	the	Pad	command	and	click	the	Sketch	icon	on	the	Pad	Definition	dialog.
4.	 Click	on	the	YZ	plane.
5.	 Create	a	rectangular	sketch,	and	then	click	Exit	workbench.



6.	 On	the	Pad	Definition	dialog,	type-in	40	in	the	Length	box.
7.	 Check	the	Mirror	extent	option.
8.	 Click	OK	to	complete	the	Pad	feature.

9.	 On	the	Sketcher	toolbar,	click	Sketch	>	Positioned	Sketch.

	

10.	 Click	on	the	top	face	of	the	part	geometry.
11.	 On	 the	 Sketch	 Positioning	 dialog,	 under	 the	 Origin	 section,	 select	 Type	 >

Intersection	2	Lines.
12.	 Click	on	the	edges	of	the	part	geometry,	as	shown	below.

13.	 On	the	dialog,	check	the	Reverse	H	and	Reverse	V	options.
14.	 Click	OK	to	start	the	sketch.
15.	 Create	a	rectangular	sketch	and	click	Exit	workbench.



16.	 Activate	the	Pocket	command.
17.	 Create	the	Pocket	feature	of	30	mm	depth.

18.	 Activate	the	Hole	command	and	click	on	the	bottom	face	of	the	Pocket	feature.

19.	 On	the	Hole	Definition	dialog,	click	Extension	>	Up	to	last.
20.	 Set	the	Diameter	value	to	8.
21.	 Click	the	Type	tab	and	select	Counterbored	from	the	drop-down.
22.	 Type-in	18	and	3	in	the	Diameter	and	Depth	boxes,	respectively.
23.	 Click	the	Extension	tab,	and	then	click	the	Positioning	sketch	icon.
24.	 Apply	constraints	to	position	the	hole.



	

25.	 Click	Exit	workbench,	and	then	click	OK	to	create	the	counterbored	hole.

26.	 Activate	the	Hole	 command	and	click	on	the	top	face	of	the	part	geometry.
27.	 Click	the	Type	tab	and	select	Simple	from	the	drop-down.
28.	 Click	the	Thread	Definition	tab	and	check	the	Threaded	option.
29.	 Under	the	Thread	Definition	section,	select	Type	>	Metric	Thin	Pitch.
30.	 Click	OK	on	the	Warning	message.
31.	 Select	Thread	Description	>	M12X1.5.

	

	



32.	 Click	the	Extension	tab,	and	the	click	the	Positioning	sketch	 icon.
33.	 Add	constraints	to	define	the	hole	location.

	

34.	 Click	Exit	workbench,	and	then	click	OK	to	create	a	threaded	hole.

35.	 On	the	Transformation	Features	toolbar,	click	Pattern	drop-down	>	Rectangular
Pattern	 (or)	click	Insert	>	Transformation	Features	>	Rectangular	Pattern	on
the	Menu.

36.	 On	the	Rectangular	Pattern	Definition	dialog,	under	the	First	Direction	tab,	select
Parameters	>	Instance(s)	&	Spacing.

37.	 Type-in	2	and	100	in	the	Instance(s)	and	Spacing	boxes.
38.	 Under	 the	Reference	Direction	 section,	 click	 in	 the	Reference	 element	 selection

box,	and	then	click	on	the	top	front	edge	of	the	part	geometry.

39.	 Under	 the	Object	 to	Pattern	 section,	click	 in	 the	Object	 selection	box	and	select
the	Pocket	feature.

40.	 Under	 the	 Second	 Direction	 section,	 type-in	 2	 and	 55	 in	 the	 Instance(s)	 and
Spacing	boxes,	respectively.



41.	 Under	 the	Reference	Direction	 section,	 click	 in	 the	Reference	 element	 box	 and
click	on	the	top	side	edge	of	the	part	geometry.

42.	 Click	the	Reverse	button,	and	then	click	OK	to	pattern	the	Pocket	feature.

43.	 Likewise,	pattern	the	counterbored	hole.	The	pattern	parameters	are	same.

44.	 On	the	Transformation	Features	toolbar,	click	the	Mirror	 icon	(or)	click	Insert
>	Transformation	Features	>	Mirror	on	the	Menu.

45.	 In	the	Specification	Tree,	click	the	zx	plane	to	define	the	mirror	plane.

46.	 On	the	Mirror	Definition	dialog,	click	in	the	Object	 to	mirror	 selection	box	and
select	the	threaded	hole	feature.

47.	 Click	OK	to	mirror	the	selected	features.



48.	 Activate	the	Hole	command	and	select	the	front	face	of	the	part	geometry.
49.	 On	the	Hole	Definition	dialog,	click	Extension	>	Up	to	last.
50.	 Type-in	40	in	the	Diameter	box
51.	 Under	the	Type	tab,	select	Counterbored	from	the	drop-down	and	type	50	and	15

in	the	Diameter	and	Depth	boxes,	respectively.
52.	 Click	the	Thread	Definition	tab	and	uncheck	the	Threaded	option.
53.	 Under	the	Extension	tab,	click	the	Positioning	sketch	icon,	and	then	add	constraints

to	define	the	location	of	the	hole.

54.	 Exit	the	sketch,	and	then	click	OK.

55.	 Draw	a	sketch	on	the	front	face	of	the	pat	geometry	and	create	a	Pocket	throughout
the	geometry.



56.	 Fillet	the	sharp	edges	of	the	Pocket	features.	The	fillet	radius	is	2	mm.

57.	 Save	and	close	the	part	file.

	

	

	

	



Questions
1.	 Describe	the	procedure	to	create	a	mirror	feature.
2.	 List	any	two	layouts	to	create	patterns.
3.	 What	 is	 the	 difference	 between	 the	 Mirror	 Feature	 and	 Mirror	 Geometry

command?
4.	 Describe	the	procedure	to	create	a	helical	pattern.
5.	 List	the	methods	to	define	spacing	in	a	linear	pattern.

	



Exercises
Exercise	1

	

	

	

	

	

	

	

	

	

	

	

	

	



	

	

	

	

	

	

	

	

	

	

Exercise	2



	

	

	

	

	

	

	

	

	

	

	

	

	

	

	

	



	

	

	

	



	

	



Chapter	6:	Rib	Features
	

The	Rib	command	 is	one	of	 the	basic	 commands	available	 in	CATIA	 that	 allow	you	 to
generate	a	 solid	geometry.	 It	 can	be	used	 to	create	 simple	geometry	as	well	 as	complex
shapes.	 A	 rib	 is	 composed	 of	 two	 items:	 a	 cross-section	 and	 a	 path.	 The	 cross-section
controls	 the	 shape	 of	 rib	while	 the	 path	 controls	 its	 direction.	 For	 example,	 look	 at	 the
angled	cylinder	shown	in	figure.	This	is	created	using	a	simple	rib	with	the	circle	as	the
profile	and	an	angled	line	as	the	path.

	

By	the	making	the	path	a	bit	more	complex,	you	can	see	that	a	rib	allows	you	to	create	the
shape	you	would	not	be	able	to	create	using	commands	such	as	Pad	or	Revolve.

	

	

The	topics	covered	in	this	chapter	are:

	



Create	Simple	rib	features
Avoiding	errors	and	intersections
Various	types	of	center	curves	that	can	be	used	to	create	rib	features
Merging	end	faces	of	the	rib
Create	Slot	features

	

	

The	Rib	command

	

This	type	of	rib	requires	two	elements:	a	center	curve	and	profile.	The	profile	defines	the
shape	of	the	rib	along	the	center	curve.	A	center	curve	is	used	to	control	the	direction	of
the	profile	and	it	can	be	a	sketch	or	an	edge.

	

1.	 To	create	a	rib,	you	must	first	create	a	center	curve	and	a	profile.
2.	 Create	a	center	curve	by	drawing	a	sketch.	It	can	be	an	open	or	closed	sketch.

3.	 Activate	the	Plane	command	and	create	a	plane	normal	to	the	path.
4.	 Sketch	the	profile	on	the	plane	normal	to	the	path.



5.	 On	 the	 Sketch-Based	 Features	 toolbar,	 click	 the	 Rib	 button	 (or)	 click	 Insert	 >
Sketch-Based	Features	>	Rib	on	the	Menu	bar.	As	you	activate	the	Rib	command,	a
dialog	appears	showing	different	options	to	create	the	rib.

6.	 Select	the	profile	and	center	curve.
7.	 Click	OK.

	

CATIA	will	not	allow	the	sweep	to	result	in	a	self-intersecting	geometry.	As	the	profile	is
swept	along	a	path,	it	cannot	comeback	and	cross	itself.	For	example,	if	the	profile	of	the
sweep	 is	 larger	 than	 the	 curve,	 the	 resulting	 geometry	will	 intersect	 and	 the	 sweep	will
fail.

	

	



	

A	rib	profile	must	be	created	as	a	sketch.	However,	a	center	curve	can	be	a	sketch,	curve,
or	edge.	The	following	illustrations	show	various	types	of	center	curves	and	resultant	rib
features.

	

Profile	Control



The	 profile	 control	 options	 define	 the	 orientation	 of	 the	 resulting	 geometry.	 The	Keep
angle	option	sweeps	the	profile	 in	 the	direction	normal	 to	 the	center	curve.	The	Pulling
Direction	option	sweeps	the	profile	in	the	along	the	direction	that	you	define.

	

You	can	also	use	the	Pulling	Direction	option	to	sweep	the	profile	and	path,	which	are	not
normal	to	each	other.

	

1.	 Activate	the	Rib	command	and	select	Profile	Control	>	Pulling	Direction.
2.	 Select	the	plane	parallel	to	the	profile	and	path.	This	defines	the	pulling	direction.
3.	 Check	the	Move	profile	to	path	option.
4.	 Select	the	profile	and	path.



The	Reference	Surface	option	under	the	Profile	Control	section	will	be	useful	while
sweeping	a	profile	along	a	non-planar	path.	For	example,	define	a	path	and	cross-section
similar	to	the	one	shown	in	figure.	Select	the	profile	and	path

	

On	the	dialog,	select	Profile	Control	>	Reference	Surface	and	click	on	the	top	surface.
The	rib	will	be	created	by	maintaining	contact	with	the	top	surface.



Use	the	Merge	end	faces	option	to	merge	the	end	faces	of	the	rib	feature	with	the	adjacent
model	faces.	You	can	use	this	option	for	the	cases	similar	to	the	following	one.

	

Use	 the	Thick	Profile	 option	 to	create	a	 shelled	 rib	 feature.	This	option	can	be	used	 to
create	pipes.



The	Slot	command
In	addition	to	adding	rib	features,	CATIA	allows	you	to	remove	geometry	using	the	Slot
command.

	

1.	 On	 the	 Sketch-Based	 Features	 toolbar,	 click	 the	 Slot	 button	 (or)	 click	 Insert	 >
Sketch-Based	Features	>	Slot	on	the	Menu	bar.

2.	 Select	the	profile	and	center	curve	from	the	model	geometry.

3.	 Click	Preview	on	the	dialog.	You	will	notice	that	slot	is	not	created	throughout	the

geometry.	



4.	 On	the	dialog,	check	the	Merge	slot’s	ends	option.	The	resultant	swept	cutout	will	be
throughout	the	geometry.	Click	OK.

	

	

	

	



	

Examples
Example	1
In	this	example,	you	will	create	the	part	shown	below.

	

1.	 Start	CATIA	V5-6R2015.
2.	 Open	a	new	part	file.
3.	 Draw	the	sketch	on	the	YZ	plane,	as	shown	in	figure.
4.	 Click	Exit	workbench	to	complete	the	sketch.



5.	 On	the	Reference	Elements	toolbar,	click	the	Plane	 icon.

	

	

6.	 On	the	Plane	Definition	dialog,	click	Plane	type	>	Normal	to	curve.
7.	 Click	on	the	end-point	of	the	sketch	to	define	the	plane	location.

8.	 Click	OK	to	create	the	plane.

9.	 Start	a	sketch	on	the	new	plane.
10.	 Draw	a	circle	and	make	its	center	coincident	with	endpoint	of	the	previous	sketch.



11.	 Click	the	Exit	workbench	icon.
12.	 On	 the	 Sketch-Based	 Features	 toolbar,	 click	 the	 Rib	 icon	 (or)	 click	 Insert	 >

Sketch-Based	Features	>	Rib	on	the	Menu.
13.	 Select	the	first	sketch	to	define	the	Center	curve.
14.	 On	 the	Rib	Definition	 dialog,	 check	 the	Thick	Profile	 option	 and	 type-in	 14	 in	 the

Thickness	1	box.
15.	 Click	OK	to	create	the	Rib	feature.

16.	 Activate	the	Pad	command	and	click	the	Sketch	 icon
17.	 Click	on	the	front-end	face	of	the	Rib	feature.

18.	 On	 the	 3D	 Geometry	 toolbar,	 click	 Project	 3D	 Elements	 and	 click	 on	 the	 inner
circular	edge.

19.	 On	the	Projection	dialog,	click	OK	to	project	the	curve	onto	the	sketch	plane.
20.	 Draw	a	circle	of	115	diameter.



	

21.	 Click	Exit	workbench	to	complete	the	sketch.
22.	 Type-in	20	 in	 the	Length	box.	Click	 the	Reverse	Direction	and	OK	 to	 complete	 the

Pad	feature.

	

23.	 Create	a	hole	of	12	diameter	on	the	Pad	feature.

	

24.	 On	 the	 Transformation	 Features	 toolbar,	 click	 Pattern	 drop-down	 >	 Circular
Pattern .

25.	 On	 the	 Circular	 Pattern	 Definition	 dialog,	 select	 Parameters	 >	 Instance(s)	 &
angular	spacing.

26.	 Type-in	6	and	60	in	the	Instance(s)	and	Angular	spacing	boxes,	respectively.
27.	 Under	the	Reference	Direction	section,	click	in	the	Reference	element	box	and	select

the	outer	cylindrical	face	of	the	Pad	feature.
28.	 Under	the	Object	to	Pattern	section,	click	in	the	Object	box	and	select	the	hole.



29.	 Click	OK	to	pattern	the	hole.

30.	 On	the	Reference	Elements	toolbar,	click	the	Point	 icon.
31.	 On	 the	Point	Definition	 dialog,	 type-in	0,	 -20	 and	0	 in	X,	Y,	 and	Z	boxes	 and	 then

click	OK.
32.	 On	the	Transformation	Features	toolbar,	click	Pattern	drop-down	>	User	Pattern

.
33.	 Click	on	the	new	reference	point.

34.	 On	 the	User	Pattern	Definition	 dialog,	 click	 in	 the	Object	 box	 and	 select	 the	Pad
feature.

35.	 Click	OK	to	pattern	the	Pad	feature.

36.	 On	the	Reference	Elements	toolbar,	click	the	Point	 icon.
37.	 On	 the	Point	Definition	 dialog,	 type-in	0,	 -10	 and	0	 in	X,	Y,	 and	Z	boxes	 and	 then

click	OK.
38.	 Activate	the	User	Pattern	command	and	select	the	reference	point.
39.	 Click	in	the	Object	box	and	select	the	Circular	pattern	from	the	Specification	tree.
40.	 Click	OK	to	pattern	the	circular	pattern.



41.	 Change	the	model	view	orientation.
42.	 Save	and	close	the	part	file.

	

Questions
1.	 List	the	types	of	path	that	can	be	used	to	create	Rib	features.
2.	 What	is	the	use	of	Merge	slot	ends	option?
3.	 Why	do	we	use	the	Reference	Surface	option	in	the	Rib	command?
4.	 What	is	the	use	of	Pulling	Direction	option?

	

	

Exercises
Exercise1



	
	
	
	



	





Chapter	7:	Multi	Section	Solids
	
The	Multi	Section	Solid	command	is	one	of	the	advanced	commands	available	in	CATIA
that	allows	you	to	create	simple	as	well	as	complex	shapes.	A	basic	multi	section	solid	is
created	 by	 defining	 two	 cross-sections	 and	 joining	 them	 together.	 For	 example,	 if	 you
create	 a	 loft	 feature	 between	 a	 circle	 and	 a	 square,	 you	 can	 easily	 change	 the	 cross-
sectional	shape	of	 the	solid.	This	ability	is	what	separates	the	multi	section	solid	feature
from	the	rib	feature.

	
The	topics	covered	in	this	chapter	are:

	

Basic	Multi-sections	Solid
Multi	Section	Solids
Removed	Multi	Section	Solids

	

The	Multi-sections	Solid	command
This	command	creates	a	solid	feature	between	different	cross-sections.

	

1.	 To	create	this	type	of	feature,	first	create	two	or	more	sections	on	different	planes.	The
planes	can	be	parallel	or	perpendicular	to	each	other.

2.	 On	 the	 Sketch-Based	 Features	 toolbar,	 click	 the	Multi-sections	 Solid	 button	 (or)
Insert	>	Sketch-Based	Features	>	Multi-sections	Solid	on	the	Menu	bar.

3.	 Select	two	or	more	sections	to	define	the	multi	section	solid.

You	have	to	ensure	that	the	closing	points	of	the	cross-sections	should	be	on	same	corners.
For	example,	if	the	closing	point	of	the	first	section	is	on	the	left	corner,	then	the	closing



points	on	other	cross-sections	 should	also	be	on	 the	 left	 corner.	 If	 they	are	not	on	same
corners,	 then	click	 the	 right	mouse	button	on	anyone	of	 the	cross-sections	on	 the	dialog
and	 select	Replace	 Closing	 Point.	 Click	 on	 the	 corner	 point	 matching	 with	 the	 other
section.

4.	 Click	the	Preview	button.	The	model	preview	updates	immediately,	as	shown	below.

5.	 Now,	 you	 have	 to	 define	 supports	 for	 the	 cross-sections.	 Click	 on	 anyone	 of	 the
sections	on	the	dialog	and	select	the	absolute	coordinate	system	of	the	section.

	



6.	 Likewise,	and	click	on	the	other	sections	and	click	on	its	absolute	coordinate	system.

	

	

The	shape	of	a	simple	multi	section	solid	is	controlled	by	the	cross-sections	and	the	plane
location.	However,	the	behaviour	of	the	side	faces	can	be	controlled	by	the	Continuity
between	the	cross-sections.	If	you	would	like	to	change	the	appearance	of	the	side	faces,
you	can	change	the	Continuity	of	the	cross-sections	of	the	multi	section	solid.	For
instance,	click	on	the	first	cross-section	in	the	dialog,	and	then	select	Continuity	>
Tangent.	Click	Preview	to	view	the	changes.	You	can	notice	that	the	beginning	of	the
solid	starts	in	a	direction	normal	to	the	cross-section.



If	you	select	Continuity	>	Curvature,	 the	side	faces	will	maintain	curvature	continuity
with	the	first	cross-section.

Likewise,	select	the	second	cross-section	from	the	dialog	and	change	the	continuity	type.

	

7.	 Click	OK	to	complete	the	feature.

	

Types	of	the	Cross-sections
In	 addition	 to	 2D	 sketches,	 you	 can	 also	 use	 different	 element	 types	 to	 define	 cross-
sections	by	using	different	element	types.	For	instance,	you	can	use	existing	model	faces,
surfaces,	and	curves

	
Couplings
Sections	 used	 for	 creating	 multi	 section	 solids	 should	 have	 a	 matching	 number	 of
segments.	For	example,	a	three-sided	section	will	loft	nicely	to	another	three-sided	section
despite	the	differences	in	the	shape	of	the	individual	segments.	The	Multi	Section	Solid
command	does	a	good	job	of	generating	smooth	faces	to	join	them.



On	the	other	hand,	a	four-sided	section	and	two-sided	section	will	result	in	an	error.

	

To	get	 the	desired	 result,	you	have	 to	break	one	of	 the	 sections	 so	 that	 they	have	equal
number	of	segments.



	

1.	 Click	Cancel	on	the	Multi-sections	Solid	Definition	dialog	and	double-click	on	the
arc	to	activate	its	sketch.

2.	 Activate	the	Break 	command	(click	Insert	>	Operations	>	Relimitations	>	Break
on	the	Menu	bar)	and	break	the	arc	into	three	segments.	You	can	also	use	dimensions
to	define	the	exact	location	of	the	split	points.

3.	 Now,	exit	the	Sketcher	workbench	and	activate	the	Multi-sections	Solid	command.
4.	 Select	the	sections	one	by	one.
5.	 On	the	Multi-sections	Solid	Definition	dialog,	click	the	Coupling	tab.
6.	 Select	 the	 vertices	 of	 the	 section	 1	 and	 section	 2,	 as	 shown	 below.	 This	 creates	 a

coupling.

7.	 Likewise,	create	other	couplings	using	the	vertices.



8.	 Click	OK	to	complete	the	feature.

	

Spines
When	you	create	a	multi	section	solid,	a	spine	is	defined	between	the	sections,
automatically.	The	spine	controls	the	way	the	multi	section	solid	is	transformed	between
the	sections.	You	can	also	define	the	spine	using	a	curve	or	sketch	element.

	
1.	 Activate	the	Multi-sections	Solid	command	and	select	the	sections.

2.	 Ensure	that	the	arrows	on	the	section	point	in	the	right	direction.
3.	 Click	Preview	to	view	the	resulting	solid.



4.	 Click	on	the	Spine	tab	and	select	the	curve	passing	through	the	section.	This	defines
the	spine.

5.	 Click	OK	to	create	the	solid.

Guides
Similar	to	Continuity	options,	guides	allow	you	to	control	the	behaviour	of	a	multi
sections	solid	between	cross-sections.	You	can	create	guides	by	using	2D	sketches.	You
can	also	use	the	3D	Spline	command	to	create	guided	curves.	Ensure	that	the	guides	touch
the	cross-sections.



1.	 Now,	activate	the	Multi	Section	Solid	command	and	select	the	cross-sections.
2.	 To	select	guide	curves,	click	the	Guides	tab	on	the	dialog.
3.	 Click	in	the	Guides	list	and	select	the	first	and	second	guides.
4.	 Click	the	Preview	button.	You	will	see	that	the	preview	updates.

Relimitation
The	Relimitation	options	limits	the	transformation	of	the	multi	sections	solids	to	the	start
and	end	sections,	as	shown	below.

If	you	want	to	create	the	multi	section	solid	up	to	the	complete	length	of	the	spine	or
guides,	then	click	the	Relimitation	tab	on	the	dialog.	Uncheck	the	Relimited	on	start



section	and	Relimited	on	end	section	options.	Click	Preview	to	view	the	relimited	solid.

Removed	Multi-sections	Solid
Like	other	standard	features	such	as	pad,	revolve	and	rib,	the	multi-sections	solid	feature
can	be	used	to	add	material.	However,	it	can	also	be	used	to	remove	material.	You	can	do
this	by	using	the	Removed	Multi-sections	Solid	command.	Activate	this	command	(click
the	Removed	Multi-sections	Solid	button	on	the	Sketch-Based	Features	toolbar)	and
select	the	cross-sections.	Ensure	that	the	arrows	on	the	cross-sections	point	in	the	same
direction.	Click	Preview	and	OK	to	create	the	feature.

	

	



	

	

	

	

	

	

	

	

	

	

	

	

	

	

	

Examples
Example	1
In	this	example,	you	will	create	the	part	shown	below.

	



	

1.	 Start	CATIA	V5-6R2015.
2.	 Open	a	new	part	file.
3.	 Start	a	new	sketch	on	the	xy	plane	and	draw	a	circle	of	340	mm	diameter.

4.	 Exit	the	sketch.
5.	 Create	the	Pad	feature	with	40	mm	thickness.



6.	 On	the	Reference	Elements	toolbar,	click	the	Plane	 icon.
7.	 Click	on	the	top	face	of	the	geometry	and	type-in	315	in	the	Offset	box.
8.	 Click	OK	to	create	an	offset	plane.
9.	 Start	a	sketch	on	the	offset	plane.
10.	 Draw	a	circle	of	170	mm	diameter	and	add	dimensions	to	it.	Exit	the	sketch.

11.	 On	the	Sketch-Based	Features	toolbar,	click	the	Multi-sections	Solid	 icon.	The
first	section	will	be	selected,	automatically.

12.	 Click	on	the	circular	edge	of	the	base	to	define	the	second	section.

13.	 Ensure	that	the	arrows	point	in	same	direction.	If	they	point	in	opposite	direction,	then
click	on	anyone	of	the	arrow	reverse	its	direction.

14.	 Click	OK	to	create	the	Multi-section	solid	feature.

	



15.	 Activate	the	Pad	command	and	click	on	the	top	face	of	the	Multi-section	solid	feature.
16.	 Click	Yes	on	the	Warning	message.

	

	

17.	 Select	the	xy	plane	on	the	Specification	tree.
18.	 Type-in	40	in	the	Length	box,	and	then	click	OK	to	create	the	Pad	feature.

19.	 On	the	Transformation	Features	toolbar,	click	the	Mirror	 icon,	and	then	select	the
zx	plane	to	define	the	mirroring	element.

20.	 Click	OK	to	mirror	the	entire	solid	body.



21.	 On	the	Dress-up	Features	toolbar,	click	the	Shell	 icon.
22.	 Click	on	the	flat	faces	of	the	model	geometry.

23.	 On	the	Shell	Definition	dialog,	type-in	2	in	the	Default	inside	thickness	box.
24.	 Click	OK.	The	part	geometry	is	shelled.

25.	 Save	and	close	the	part	file.



	

Questions
1.	 Describe	the	procedure	to	create	a	Multi-sections	solid	feature.
2.	 List	the	Continuity	options.
3.	 List	 the	type	of	elements	 that	can	be	selected	to	create	a	Multi-sections
solid	feature.

	

	
	
	
	
	
	
	
Exercises
Exercise	1



	

	
	
	



	





Chapter	8:	Additional	Features	and
Multibody	Parts

CATIA	V5	 offers	 you	 some	 additional	 commands	 and	 features	 which	 will	 help	 you	 to
create	complex	models.	These	commands	are	explained	in	this	chapter.

	

The	topics	covered	in	this	chapter	are:

	

Stiffeners
Solid	Combine
Multi-body	parts
Boolean	Operations



	Stiffener
This	command	creates	stiffening	features	to	add	structural	stability,	strength	and	support	to
your	 designs.	 Just	 like	 any	 other	 sketch-based	 feature,	 a	 stiffener	 requires	 a	 two
dimensional	sketch.

	

1.	 Create	a	sketch,	as	shown	in	figure.

2.	 On	 the	Sketch-Based	Features	 toolbar,	 click	Advanced	 drop-down	>	Stiffener	 (or)
click	Insert	>	Sketch-Based	Features	>	Stiffener	on	the	Menu	bar.

3.	 Select	the	sketch;	the	preview	of	the	geometry	appears.	You	can	add	material	to	either
side	of	the	sketch	line	or	evenly	to	both	sides.

4.	 Check	the	Neutral	Fiber	option	to	add	material	to	both	sides	of	the	sketch	line.
5.	 Type-in	the	thickness	value	of	the	stiffener	feature	in	the	Thickness1	box.
6.	 You	 can	 click	 the	 Reverse	 direction	 button	 to	 change	 the	 side	 of	 the	 material

(optional).
7.	 You	can	define	the	direction	of	the	rib	feature	by	using	the	From	Side	or	From	Top

option.



8.	 Click	OK	to	complete	the	feature.

	



Solid	Combine
This	command	creates	a	solid	body	by	using	two	sketches,	which	are	perpendicular	to
each	other.

	

1.	 Create	two	sketches,	as	shown	in	figure.

2.	 On	the	Sketch-Based	Features	toolbar,	click	Advanced	drop-down	>	Solid	Combine
(or)	click	Insert	>	Sketch-Based	Features	>	Solid	Combine	on	the	Menu	bar.

3.	 Select	the	two	sketches.
4.	 Click	OK.



Multi-body	Parts
CATIA	V5	allows	the	use	of	multiple	bodies	when	designing	parts.	This	opens	the	door	to
several	design	techniques	that	would	otherwise	not	be	possible.	In	this	section,	you	will
learn	some	of	these	techniques.

	

Creating	Multi-bodies
The	number	of	bodies	in	a	part	can	change	throughout	the	design	process.	CATIA	V5
makes	it	easy	to	create	separate	single	bodies	and	multiple	bodies,	and	combine	multiple
bodies	into	single	bodies.

	

1.	 In	order	to	create	multiple	bodies	in	a	part,	first	create	a	solid	body,	and
then	click	Insert	>	Body	on	the	Menu	bar.	A	new	body	is	added	to	the
Specification	Tree	and	the	previous	body	is	hidden.

	

	

2.	 Now,	create	another	solid	body	using	anyone	of	the	modeling	tools.

	

Insert	in	new	body
The	Insert	in	new	body	command	can	be	used	to	separate	a	feature	of	the	body,	and	then
insert	it	in	a	new	body.	This	command	can	be	used	to	perform	local	operations.	For
example,	if	you	apply	the	shell	feature	to	the	front	portion	of	the	model	shown	in	figure,
the	whole	model	will	be	shelled.	To	solve	this	problem,	you	must	split	the	solid	body	into
multiple	bodies.



1.	 To	perform	shell	operation	to	the	front	portion,	you	must	create	it	as	a	separate	feature.
2.	 Expand	the	Specification	Tree	and	select	the	feature	of	the	front	portion.

3.	 On	the	Menu	bar,	click	Insert	>	Insert	in	new	body.

	

You	will	 notice	 that	 a	 new	body	 is	 created	 and	 the	 selected	 feature	 is	 inserted	 into	 that
body.	In	addition,	the	Assemble	operation	is	performed	between	the	new	body	and	main
body.

	

	

4.	 Now,	click	the	right	mouse	button	on	the	new	body	and	select	Define	In	Work	Object.
This	activates	the	new	body.



	

5.	 Now,	activate	the	Shell	command	and	perform	the	shell	operation.

6.	 Click	the	right	mouse	button	on	the	main	body	and	select	Define	In	Work	Object.

	Assemble
This	command	assembles	two	bodies	into	a	single	one.

1.	 Create	two	or	more	bodies.
2.	 On	 the	Boolean	Operations	 toolbar,	 click	 the	Assemble	 button	 (or)	 click	 Insert	 >

Boolean	Operations	>	Assemble	on	the	Menu	bar.
3.	 Click	on	the	body	to	assemble,	and	then	click	on	main	body.
4.	 Click	OK.

	

The	 geometry	 of	 the	 resultant	 body	 will	 depend	 upon	 the	 type	 of	 bodies	 used.	 For
example,	if	you	assemble,	a	body	created	using	a	Pad	feature;	resultant	body	will	be	the



addition	of	two	bodies.

If	you	assemble	a	body	created	using	a	Pocket	Feature,	then	it	will	result	in	a	pocket	in	the
resultant	body.



	Add
This	command	combines	two	separate	bodies.

	

1.	 On	the	Boolean	Operations	toolbar,	click	Boolean	Operations	drop-down	>	Add	(or)
click	Insert	>	Boolean	Operations	>	Add	on	the	Menu	bar.

2.	 Select	the	two	bodies	and	click	OK.

Remove
This	command	performs	the	function	of	subtracting	one	solid	body	from	another.

	

1.	 On	the	Boolean	Operations	toolbar,	click	Boolean	Operations	drop-down	>	Remove
(or)	click	Insert	>	Boolean	Operations	>	Remove	on	the	Menu	bar.

2.	 Select	tool	body	and	the	target	body.

Tool

Target



3.	 Click	OK	to	subtract	the	tool	body	from	the	target.

	Intersect
By	using	the	Intersect	command,	you	can	generate	bodies	defined	by	the	intersecting
volume	of	two	bodies.

	

1.	 On	the	Boolean	Operations	toolbar,	click	Boolean	Operations	drop-down	>
Intersect	(or)	click	Insert	>	Boolean	Operations	>	Intersect	on	the	Menu	bar.

2.	 Select	two	bodies.

3.	 Click	OK	to	see	the	resultant	single	solid	body



Union	Trim
By	using	the	Union	Trim	command,	you	can	combine	two	bodies	and	trim	the	unwanted
portion.

	

1.	 Create	two	bodies.
2.	 Ensure	that	the	Partbody	is	not	active.
3.	 On	the	Boolean	Operations	toolbar,	click	the	Union	Trim	button	(or)	click	Insert	>

Boolean	Operations	>	Union	Trim	on	the	Menu	bar.
4.	 Click	on	the	second	body.	The	Trim	Definition	dialog	appears.
5.	 On	the	Trim	Definition	dialog,	click	the	Faces	to	remove	box	and	select	the	faces	to

remove.
6.	 Click	the	Faces	to	Keep	box	and	select	faces	to	keep.

7.	 Click	OK.

	Remove	Lump
This	command	trims	a	lump	of	body	from	the	main	part	body.

	

1.	 Create	two	bodies	and	combine	them.
2.	 On	the	Boolean	Operations	toolbar,	click	the	Remove	Lump	button	(or)	click	Insert



>	Boolean	Operations	>	Remove	Lump	on	the	Menu	bar.
3.	 Click	on	the	part	body.
4.	 On	the	Remove	Lump	dialog,	click	the	Faces	to	remove	box.
5.	 Select	the	face	of	the	body	to	be	trimmed.

6.	 Click	OK.

	

	

	

	



Examples
Example	1	(Millimetres)
In	this	example,	you	will	create	the	part	shown	next.

	

1.	 Start	CATIA	V5-6R2015.

2.	 Open	a	new	part	file.
3.	 Create	the	rectangular	base	on	the	XY	plane.	The	extrusion	depth	is	20	mm.



4.	 Construct	the	second	feature	on	the	YZ	plane.	The	extrusion	depth	is	20	mm.

5.	 On	the	Sketch-Based	Features	toolbar,	click	Advanced	drop-down	>	Stiffener	
(or)	click	Insert	>	Sketch-Based	Features	>	Stiffener	on	the	Menu.

6.	 On	the	Stiffener	Definition	dialog,	click	on	the	Sketch	 icon	and	select	the	yz	plane.
7.	 Draw	a	line,	which	is	tangent	to	the	curved	face	of	the	second	feature	and	connected	to

the	top	right	vertex	of	the	first	feature.



8.	 Click	Exit	workbench.
9.	 On	the	Stiffener	Definition	dialog,	under	the	Thickness	section,	uncheck	the	Neutral

Fiber	option	and	click	the	Reverse	direction	button.
10.	 Type-in	10	in	the	Thickness	box	and	click	OK	to	create	the	stiffener.	

	

11.	 Activate	the	Pocket	 command	and	click	the	Sketch	 icon	on	the	dialog.
12.	 Click	 on	 the	 front	 face	 of	 the	 second	 feature,	 and	 then	 draw	 the	 sketch	 for	 the	 slot

feature.

	

13.	 Exit	the	sketch	and	create	the	Pocket	feature.



14.	 Create	another	Pocket	feature	on	the	front	face	of	the	base.

	

15.	 Add	an	edge	fillet	and	counterbored	hole	to	the	model	geometry.



16.	 Save	and	close	the	file.

	

	

Questions
1.	 What	is	the	use	of	the	Stiffener	command?
2.	 Why	do	we	create	multi	body	parts?
3.	 How	do	you	split	a	single	body	into	multiple	bodies?

	



Exercises
Exercise	1

Exercise	2



	

Exercise	3	(Inches)



	

	

	

	

	

	





Chapter	9:	Modifying	Parts
In	design	process,	it	is	not	required	to	achieve	the	final	model	in	the	first	attempt.	There	is
always	a	need	to	modify	the	existing	parts	to	get	the	desired	part	geometry.	In	this	chapter,
you	will	learn	various	commands	and	techniques	to	make	changes	to	a	part.

	

The	topics	covered	in	this	chapter	are:

	

Edit	Sketches
Edit	Feature	Parameters
Edit	Feature	definition
Deactivate	and	activate	features
Change	sketch	support



Edit	Sketches
Sketches	form	the	base	of	a	3D	geometry.	They	control	the	size	and	shape	of	the	geometry.
If	you	want	to	modify	the	3D	geometry,	most	of	the	times,	you	are	required	to	edit
sketches.

	

1.	 To	do	this,	click	the	right-mouse	button	on	the	feature	to	edit	and	select
Featurename.object	>	Edit	Sketch.

2.	 Now,	modify	the	sketch	and	click	Exit	workbench .	You	will	notice	that	the	part
geometry	updates	immediately.



Edit	Feature	Definition
Features	are	the	building	blocks	of	model	geometry.

	

1.	 To	modify	a	feature,	click	the	right	mouse	button	on	it	and	select	Featurename.object
>	Definition.	The	dialog	related	to	the	feature	appears.

2.	 On	this	dialog,	modify	the	parameters	of	the	feature	and	click	OK.	The	changes	take
place	instantaneously.

	

	





Edit	Feature	Parameters
CATIA	V5	allows	you	to	modify	a	feature	by	editing	its	parametric	dimensions.

	

1.	 Click	the	right	mouse	button	on	it	and	select	Featurename.object	>	Edit	Parameters.
The	parameters	of	the	feature	appear.

	

2.	 To	edit	a	parameter,	double-click	on	it	and	type-in	a	new	value	in	the	Parameter
Definition	box.	Click	OK.

3.	 On	the	Tools	toolbar,	click	the	Update	All	 button	to	update	the	feature.



Deactivate	Features
Sometimes	you	may	need	to	deactivate	some	features	of	model	geometry.

	

1.	 To	do	this,	click	the	right	mouse	button	on	a	feature	and	select	Deactivate.

On	the	Deactivate	dialog,	check	the	Deactivate	aggregated	elements	option	if	you	want
to	deactivate	all	the	sketches	and	references	elements	related	to	the	feature.	Otherwise,
uncheck	this	option.

2.	 Click	OK	to	deactivate	the	feature.

	



Activate	Features
1.	 If	you	want	to	activate	the	deactivated	features,	then	expand	the	Specification	Tree.
2.	 Click	the	right	mouse	button	on	the	deactivated	feature	and	select	Featurename.object

>	Activate.

3.	 Click	OK.	The	feature	will	become	active	again.

	



Changing	the	Sketch	Support
CATIA	V5	allows	you	to	change	the	sketch	support	of	a	feature.

	

1.	 Expand	the	Specification	Tree	and	go	to	the	feature	to	modify.

	

2.	 Click	 the	 right	 mouse	 button	 on	 the	 sketch	 of	 the	 feature	 and	 select
Sketchname.object	>	Change	Sketch	Support.

	

	

3.	 Select	 a	 different	 plane	 to	define	 the	new	 sketch	 support.	You	 can	 select	 it	 from	 the
graphics	window	or	Specification	Tree.

4.	 On	the	Sketch	Positioning	dialog,	check	the	Move	Geometry	option	and	click	OK.
The	orientation	of	the	geometry	will	change	accordingly.



	

If	 there	 are	 any	 sketches	 or	 features	 on	 the	 geometry,	 it	may	 show	 some	warnings	 and
error	messages.	You	have	to	manually	solve	these	problems	or	avoid	changing	the	sketch
support	 when	 the	 model	 becomes	 complex.	 It	 is	 recommended	 that	 you	 select	 correct
plane	initially	based	on	model	orientation.

	



Examples
Example	1
In	this	example,	you	will	create	the	part	shown	below,	and	then	modify	it.

	

1.	 Start	CATIA	V5-6R2015	and	open	a	part	file.
2.	 Create	the	part	using	the	tools	and	commands	in	CATIA	V5.

The	Specification	Tree	of	the	part	is	given	next.



3.	 Double-click	on	the	50	mm	diameter	hole.	The	Hole	Definition	dialog	appears.

4.	 On	the	Hole	Definition	dialog,	click	the	Type	tab,	and	then	select	Counterbored
from	the	drop-down.

5.	 Set	the	counterbore	Diameter	to	50	and	Depth	to	20.
6.	 Click	the	Extension	tab	and	set	the	Diameter	to	35.	Click	OK	to	close	the	dialog.

	

7.	 Click	 the	 right	mouse	button	on	 the	 rectangular	pad	 feature	and	select	Pad.object	>
Edit	Sketch.



8.	 Modify	the	sketch,	as	shown	below.

9.	 Exit	the	sketch.
10.	 Click	 the	 right	 mouse	 button	 on	 the	 slot	 feature	 and	 select	Pocket1.object	 >	 Edit

Sketch.

11.	 Delete	 the	 length	dimension	of	 the	 slot,	 and	 then	add	a	new	dimension	between	 the
right-side	arc	and	right	vertical	edge.



12.	 Exit	the	sketch.
13.	 Double-click	on	the	small	hole,	and	then	click	the	Positioned	sketch	 button	on	the

dialog.

14.	 Delete	the	positioning	dimensions.



15.	 Create	 a	 construction	 line	 and	make	 its	 ends	 coincident	with	 the	 corners,	 as	 shown
below.

16.	 Press	the	Ctrl	key	and	select	the	hole	point	and	the	construction	line.

17.	 Activate	the	Constraint	Define	in	Dialog	Box	command.
18.	 On	the	Constraint	Definition	dialog,	check	the	Midpoint	option,	and	then	click	OK.

This	positions	the	hole	point	on	the	midpoint	of	the	construction	line.

19.	 Exit	the	sketch.



20.	 Click	OK	on	the	Hole	Definition	dialog.

21.	 Now,	change	the	size	of	the	pad	feature.	You	will	notice	that	the	slot	and	hole	are
adjusted	automatically.

22.	 Save	and	close	the	file.



Questions
1.	 How	do	you	modify	the	sketch	of	a	feature?
2.	 How	do	you	modify	a	feature	directly?
3.	 How	can	you	change	the	orientation	of	the	model?

	



Exercises
Exercise	1
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